2

I come from Fedora 22 and 23, because it had support for my BLE mouse (Microsoft Designer Mouse). I decided to switch to the "stable" 16.04 because I like Unity more than gnome. To make my mouse at least pair with my PC, I had to remove 50-bluetooth-hci-auto-poweron.rules from and uncommented autoenable=true from /etc/bluetooth/main.conf (as indicated here https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1510570).

Sometimes when I boot up the computer, the mouse works (although it stops working after a while), and sometimes don't. For example, today I restarted my pc 10 times without success. Yesterday, it worked after 3 reboots. Please help me, this is really getting annoying.

lsusb

Atheros Communications, Inc. AR3012 Bluetooth 4.0

dmesg

Bluetooth: BNEP (Ethernet Emulation) ver 1.3

Bluetooth: BNEP filters: protocol multicast

Bluetooth: BNEP socket layer initialized

Bluetooth: RFCOMM TTY layer initialized

Bluetooth: RFCOMM socket layer initialized

Bluetooth: RFCOMM ver 1.11

Bluetooth: hci0 command 0x0c52 tx timeout

bluetoothctl:

[bluetooth]# info CC:E4:52:E7:9B:9E

Device CC:E4:52:E7:9B:9E

Name: Designer Mouse

Alias: Designer Mouse

Appearance: 0x03c2

Icon: input-mouse

Paired: yes

Trusted: yes

Blocked: no

Connected: no

LegacyPairing: no

Modalias: usb:v045Ep0805d0100

[bluetooth]# connect CC:E4:52:E7:9B:9E

Attempting to connect to CC:E4:52:E7:9B:9E

Failed to connect: org.bluez.Error.Failed

It would be great if there were a way to know what differs from the fedora configuration, because on that system it worked just perfectly.

1

I solved replacing the gnome bluetooth default indicator with blueman (which is even better and has more options, I really wonder why it is not default)

cd /usr/share/upstart/sessions

sudo mv indicator-bluetooth.conf indicator-bluetooth.conf.old

sudo apt install blueman

Then I restarted and reassociated the mouse. Now it works flawlessly at any time.

0

I also have a similar problem. I'm using Ubuntu 16.04 and a Microsoft Designer Mouse. The mouse works on bootup but then stops working after a random amount of time. Turning bluetooth off and on again using the icon in the notification bar works for me, but this is really annoying.

  • Unfortunately it stopped working for me, no matter what I do, what did you do to connect the mouse? Did you follow the procedure I linked (deleting that file and enabling autoenable)? – Marc May 26 '16 at 7:28

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.