I've had Ubuntu installed on my HD for about 3 months but ever since I ran into this wireless issue I kinda lost my lust of Ubuntu. I have zero experience getting around with/ using the console command. I have a Lenovo V570. I got the driver update for the broadcom networking card via the Additional Drivers application but that did nothing. I love the look and feel of using Ubuntu but I have no technological experience for the matter. Any help would be awesome. When I scan for wireless connections while in Ubuntu, my computer picks up nothing, while on Win7 it will pick up the handful of wireless networks around my area. My wired connection is fine, but the use of not having wireless on a laptop is rather contradictory to it as a feature. Cheers!

Also, I just installed 11.10, if that helps any. Yes, I used the search before I posted this, but again I have ZERO understanding of the command stuff and need a meat and potatoes answer(s).

stephen@ubuntu:~$ sudo lshw -class network
[sudo] password for stephen: 
  *-network UNCLAIMED     
       description: Network controller
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f1900000-f1903fff
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 06
       serial: f0:de:f1:63:98:14
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8168e-2.fw ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:41 ioport:2000(size=256) memory:f1804000-f1804fff memory:f1800000-f1803fff

stephen@ubuntu:~$ rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
  • Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Nov 10 '11 at 4:46
  • please run in a terminal the following commands - copy and paste the output you see into your question: sudo lshw -class network and rfkill list all – fossfreedom Nov 10 '11 at 9:22
  • Added. 10NOV11 @ 1547 PST – Stephen Nov 10 '11 at 23:48
  • Thanks for the outputs. The driver for you BCM4313 wireless card doesn't seem to be installed. Can you try the Additional Drivers again, and make sure you are connected to the internet wiredly. – mikewhatever Nov 11 '11 at 0:02
  • So I removed the BCM4313 Driver from the Additional Drivers application, then re-activated it. Afterwards it scrolled me to a black terminal screen and then froze. Now whenever i try to boot in Ubuntu, it fails to get any farther than the Ubuntu purple/orange blend background. Should I completely delete Ubuntu from my disk and start from scratch? – Stephen Nov 11 '11 at 3:59

ok - you most probably have a similar issue as other similar laptop users:

You may be suffering from a clash with the acer-wmi kernel module.

rfkill list all says it is "acer-wireless: soft blocked: yes" then you need to run the following:

sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo nano blacklist.conf

Then add blacklist acer-wmi as a new line at the end of the file.

Save and reboot.

Rerun sudo lshw -class network and rfkill list all

You should not be soft-blocked (i.e. rfkill says no to all responses).

lshw should not say "unclaimed" - if it does then use this answer to resolve this.

  • I have no idea what I did when I tried to follow this, but my Wifi Connects now =D Ill reboot and see if it stays that way. Cheers! Edit: Was unsuccessful, will continue to retry. – Stephen Nov 11 '11 at 6:16
  • 'stephen@ubuntu:~$ rfkill list all 0: ideapad_wlan: Wireless LAN Soft blocked: no Hard blocked: no 2: phy0: Wireless LAN Soft blocked: no Hard blocked: no ' whatever it is that im doing to enable wifi over and over, after typing rfkill list all, 1: acer-wireless disappears. How do you save? -.- nublet here. – Stephen Nov 11 '11 at 6:32
  • Stephen - rfkill will just report whether you have any software blocks or hardware blocks on your wifi - there is no need to save anything. By adding blacklist acer-wmi into blacklist.conf prevents the acer-wmi module from loading and hence prevent "wifi-blocking" – fossfreedom Nov 11 '11 at 8:25
  • but everytime i reboot my computer i will have to re-enter this? this is the effect I am getting. – Stephen Nov 12 '11 at 0:27
  • That's great, solved my wireless problem! – Adam Matan Dec 24 '11 at 21:49

I had the same problem on a Lenovo B570, for some reason when you install Ubuntu 11.10 it switches off the wireless. You have to blacklist the acer-wmi as listed above then boot back into windows and turn on wireless in windows systray then reboot back into Ubuntu and walaa. Don't know why, just know after installing both Mint 11 and then Ubuntu 11.10 it is the only way it would remove the "softblocked:yes". Found this quite by accident needing wireless.


Hi there looks like you have something going on on the software level

stephen@ubuntu:~$ rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

first try

rfkill unblock all nothing ?

please post lspci -nn and lsmod.


I had a similar problem and the following worked

sudo modprobe -rv acer-wmi

If that doesn't solved your problem then update your driver from Intel. Lenovo has a faulty drivers set for wifi.

Please check this link and pick your os then download.



lenovo wireless solution for video communication.Follow the bidding Wireless is not working on Lenovo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.