2

It only appears when run with sudo.

Running Sublime-Text 3 with root permissions

Running gnome-terminal with root permissions

5
  • Can you check if it shows in the title bar on the top menu bar when you hover your pointer over these? I can only see the menu when I hover over the window's title bar.
    – user448115
    May 25 '16 at 1:52
  • @adonis Before I run unity as suggested I tried to look on the title bar and the menu bar was still missing.
    – user548254
    May 25 '16 at 3:29
  • The default location of the menu in 16.04 is on the very top. Holding Alt or hovering the mouse reveals it. I just thought to mention it because I don't think it's obvious.
    – user448115
    May 25 '16 at 3:58
  • 1
    I believe you're facing this bug: bugs.launchpad.net/ubuntu/+source/bamf/+bug/1532226
    – egmont
    May 25 '16 at 18:25
  • @adonis Yeah, I tried that. Even holding alt didn't work for me. The only way that I found was running as root and this shows a menu bar in a different position as you can see.
    – user548254
    May 26 '16 at 2:45
2

Open a terminal and type unity and hit return, after you have your desktop back close the terminal and reopen it normally. Actually i have the same problem on my second computer but i do this direct after boot up and have then menu bars everywhere. As far i know this is a known bug and a fix is in the making, just couldn't find the link anymore.

1
  • Welcome to Ask Ubuntu, if my post helped you you can accept it as an answer by clicking the checkmark beside it.
    – Videonauth
    May 25 '16 at 1:18
0

Press CTRL+ALT+T and type in unity - Once you've pressed Enter on your keyboard, it should prompt you to login. Login, and hopefully you will see your Unity desktop! In my opinion, the Unity desktop environment, including the launcher, is very organized and clean. I use the Gnome Tweak Tool and I use the Oxygen theme (GTK) to provide extra cleanse to my OS. I have Ubuntu 14.04 dual booting with Windows 7 Professional, and since the day I got Ubuntu, I haven't used Windows. Funny. Anyway, to get back on topic, press CTRL + ALT + T once more and type in sudo -s - This will prompt you for your password, and allow you to get root permissions. Once you're in the root, type in unity again and send that command into the terminal by pressing return or enter. Then, login once more, and open the Terminal, AGAIN. Simply close it, and you should be good. This worked for me on my Chromebook Pixel, and hopefully it will work for you. By the way, I didn't use ChromeOS on the Chromebook Pixel - I got Ubuntu and then erased ChromeOS off of it. Chromebook Pixel computers are basically the best laptops on the market, except for the OS. But once you've got a certain file called "crouton" it will allow you to enter a certain command into the terminal, returning in Ubuntu! You can even specify a desktop environment, but I would stick to Unity, and then manually run sudo apt-get install kubuntu-full for the clean Oxygen theme and KDE-simple cursor/window pack.

0

I figured out that easiest way to fix the problem is to reinstall ubuntu desktop.

sudo apt-get install --reinstall ubuntu-desktop

I hope this would work for you also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy