0

I got the Problem that the Keyboard Key shift+ins on the application or number pad does not work (I mean the one on the right side. Not that "ins" near the letter keys right above). The six keys near Return right above "Ins,Pos,UP,Del,End,Down" are working fine. When working with text I can make cut&paste with them. But I like more to do past with "shift+ins" on the keys on the nummber block (num is disabled for that). I have a QWERTZ German Standard Keyboard. Also I selected the right keyboard settings as I installed UBUNTU.

Why does the Key shift+ins not working on the right side and how could I change this? Thanks for your tip's.

  • What makes you think it should work? Did it work before and stopped working, or have you seen that key combination be documented somewhere? (Just curious.) – Gunnar Hjalmarsson May 24 '16 at 22:39
  • yes sure - under ever Microsoft Windows editor or in Office with the shift+key I paste the text into the editor. You have 2 Ins Key on the Keyboard. Unter Ubuntu just one is working. The other not, so I believe under Linux its a problem of the keypad layout, or mapping, what is defined anywhere in a script. I've got a standard CHERRY Keypad G230 - nothing special. Is there anyone who have a idea to solve this? – HL1234 May 25 '16 at 19:47
  • To be honest, I didn't know before I read your question that <Shift>+<Ins> could be used at all for pasting from clipboard. I use <Ctrl>+V. Maybe someone else can actually answer your question. – Gunnar Hjalmarsson May 25 '16 at 23:30
  • Yes I hope someone else can help to solve that problem. Indeed I used <Ctrl>+C to copy but not <Ctrl>+V. to paste (I don't like to stretching my fingers to much). To paste I used <Shift>+<Ins> with left hand <Shift> and the pinky on the right hand for <Ins> and on the number keypad. I wonder that under Linux this does not work? – HL1234 Jun 1 '16 at 10:13
0

I found the solution by myself. Inspired by XUbuntu: Make Shift+NumPad work like Windows I do in the KEYBOARD CONFIGURATION FILE /etc/default/keyboard change

XKBOPTIONS=""

to

XKBOPTIONS="numpad:microsoft"

save and reboot It was told "You may need to run

sudo dpkg-reconfigure keyboard-configuration

for changes to take effect." but I don't do that. After reboot the behavior of the numpad is like I know it form Microsoft Windows Keyboard settings.

I just like to post this for anyone who got the same problem. Thanks all which have tried to help me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.