(This question was not resolved. Due to time constraints Computer was restored to factory settings.)

I was attempting to upgrade from 14.04 to 16.04, but apt threw this error:

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.

What does this mean, and how can I fix it?

When I type in the command apt-cache policy apt

Shageenth@shageenth-Inspiron-3451:~$ apt-cache policy apt apt:
Installed: 1.0.1ubuntu2.11
Candidate: 1.0.1ubuntu2.11
Version table:
*** 1.0.1ubuntu2.11 0
100 /var/lib/dpkg/status
1.0.1ubuntu2 0
500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 

The error happens when I run the command:

sudo do-release-upgrade -d

and it produces the following:

Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,265 kB]
Fetched 1,265 kB in 0s (0 B/s)
authenticate 'xenial.tar.gz' against 'xenial.tar.gz.gpg'
extracting 'xenial.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done

Required depends is not installed

The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed.
  • I have deleted my answer now as I have found somebody more able to help who will post an answer soon. – user364819 May 24 '16 at 23:00
  • I also have this problem – trying to upgrade my cubieboard (linaro port) and couldn't find a solution. – adib Sep 25 '16 at 4:56

I've had the exact same problem today. Make sure your version is the latest Ubuntu 14.04 version before the upgrade. (Ubuntu 14.04.4 at this time)

Mine was stuck to Ubuntu 14.04.3 due to a bad mirror.

So first run:

sudo apt update
sudo apt dist-upgrade

Make sure the version is now Ubuntu 14.04.4 (update September 2016 : Ubuntu 14.04.5).

cat /etc/lsb-release

And start Ubuntu 16.04 installation with

sudo do-release-upgrade -d
  • 1
    My version is 14.04 already – Shageenth Sandrakumar May 25 '16 at 19:02
  • 8
    The minor version (see .3 and .4 after 14.04) is the important point. If you already had 14.04.4, the apt and dpkg would be the right version already. – cnxsoft May 27 '16 at 2:15
  • 1
    This is the correct answer, although the version is now – Chris Ostmo Aug 12 '16 at 17:28
  • 2
    In the "Software & Updates" manager, make sure that "Important security updates" and "Recommended updates" are checked if the commands in the answer aren't working for you. – Patrick Brinich-Langlois Aug 25 '16 at 5:02
  • 1
    Doesn't work. The other answer does. – matanster Sep 21 '16 at 20:28

Best to always update through the normal procedures of:

sudo apt update
sudo apt dist-upgrade

If the above fails, then you can step manually through the following. This question is outdated, but you can just change the version numbers as the links should still be the same.

To upgrade your version of apt from a terminal window, type in the following:

sudo apt-get download apt

if the above doesn't work, you can also download it with wget by running the following line:

wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.17_amd64.deb

then type in

sudo dpkg -i apt*.deb

Just tried this on my system here. Here is the output:

terrance@terrance-VirtualBox:~$ sudo apt-get download apt
[sudo] password for terrance: 
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt amd64 1.0.1ubuntu2.17 [954 kB]
Fetched 954 kB in 0s (1,127 kB/s)
terrance@terrance-VirtualBox:~$ ls
apt_1.0.1ubuntu2.17_amd64.deb  Documents  examples.desktop  Pictures  Templates
Desktop                        Downloads  Music             Public    Videos
terrance@terrance-VirtualBox:~$ sudo dpkg -i apt*.deb
(Reading database ... 168376 files and directories currently installed.)
Preparing to unpack apt_1.0.1ubuntu2.17_amd64.deb ...
Unpacking apt (1.0.1ubuntu2.17) over (1.0.1ubuntu2.11) ...
Setting up apt (1.0.1ubuntu2.17) ...
Processing triggers for man-db ( ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...

If After the steps described you see a fail due to a missing dpkg dependency you can just finish by repeating the steps with dpkg and ..

wget http://security.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg_1.18.24ubuntu1_amd64.deb
sudo dpkg -i dpkg_1.18.24ubuntu1_amd64.deb

All of the packages that are available to Ubuntu can be found here:


  • when I type in sudo apt-get download apt, I get E: Can't find a source to download version '1.0.1ubuntu2.11' of 'apt:amd64' – Shageenth Sandrakumar May 24 '16 at 23:08
  • @ShageenthSandrakumar I updated for wget to download it directly too if the apt-get does not work. – Terrance May 24 '16 at 23:12
  • 1
    @ShageenthSandrakumar Does sudo apt-get install dpkg work? – Terrance May 24 '16 at 23:32
  • 1
    In case you're looking for the ARM version (Linaro) – http://ports.ubuntu.com/ubuntu-ports/pool/main/a/apt/apt_1.0.1ubuntu2.13_armhf.deb – adib Sep 25 '16 at 5:10
  • 1
    This came up for me. wget http://security.ubuntu.com/ubuntu/pool/main/a/apt/apt_1.0.1ubuntu2.13_amd64.deb now needs to be 2.17 not 2.13 – std''OrgnlDave Mar 24 '17 at 0:35

Simple fix...Which has worked for me...

Open your Synaptic Package manager type "apt" in search box that will show you the current installed version of apt lets assume "1.0.1ubuntu1.13" just right click on it and click mark for upgrade then click apply button at the top.

after upgrade..

Make sure to close the synaptic package manager before going to run your

final command

sudo do-release-upgrade  

and it should work..


I got this error message and a very simple apt-get update apt-get upgrade solved it. The other answers are wildly innacurate -- for example the one talking about moving Ubuntu 14.04.3 to 14.04.4 via dist-upgrade -- but dist-upgrade moves to the next Ubuntu version, not minors. Minors are just a released collection of specific package versions anyways, simply by keeping your packages up to date you get at least those versions or newer. Do not run dist-upgrade unless you know what you are doing.

Not the answer you're looking for? Browse other questions tagged or ask your own question.