1

I'm a father and I was trying to get one more entry on gnucash after my youngest woke up. I had gnucash, keypass, chrome and LibreOffice calc up when my son found the power button.... Nooooooo! :D

When I restarted Ubuntu I was met with the following:

Error: no such device...
grub rescue>

I don't think the system was updating and only other software that could be running was CrashPlan.

Below is my initial attempt

grub rescue> ls

(hd0)

There is no partition recognized… I tried to change the directory to hd0, but couldn’t (no something something)

Then I started Ubuntu up in Live CD mode by “trying Ubuntu” from my original installation CD.
I ran Boot Info Script by downloading it from bootinfoscript.sourceforge.net Extracting using the default extractor (not the terminal)

Then in the terminal I wrote:

Sudo ~/Downloads/bootinfoscript

The result is posted below.

                 Boot Info Script 0.61      [1 April 2012]


============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    in partition 112 for .

sda1: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info: 

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 1000.2 GB, 1000203804160 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953523055 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1    *          2,046 1,953,521,663 1,953,519,618   5 Extended
/dev/sda5               2,048 1,953,521,663 1,953,519,616  83 Linux


"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0                                              squashfs   
/dev/sda5        bf1747fe-86af-43af-89fe-80a261162823   ext4       
/dev/sr0                                                iso9660    Ubuntu 14.04.1 LTS amd64

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop0       /rofs                    squashfs   (ro,noatime)
/dev/sda5        /media/ubuntu/bf1747fe-86af-43af-89fe-80a261162823 ext4       (rw,nosuid,nodev,uhelper=udisks2)
/dev/sr0         /cdrom                   iso9660    (ro,noatime)


=============================== StdErr Messages: ===============================

  No volume groups found


Then I tried boot-repair by entering in the terminal:

Sudo add-apt-repository ppa:yannubuntu/boot-repair
Sudo apt-get update
Sudo apt-get install -y boot-repair && boot-repair

I did the “recommended repair”

Results are posted on the below link:

Please write on a paper the following URL:
http://paste.ubuntu.com/16662512/

In case you still experience boot problem, indicate this URL to: boot.repair@gmail.com or to your favorite support forum.

But it started up in the Grub rescue mode again.

I’m a little stubborn and want to do things myself… so then I typed in the terminal of grub rescue

Grub rescue> set prefix=(hd0,1)/boot/grub
Grub rescue> set root=(hd0,1)
Grub rescue> insmod normal

No something something.

sudo fdisk -l  
Disk /dev/sda: 1000.2 GB, 1000203804160 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953523055 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0004c7e9

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2046  1953521663   976759809    5  Extended
Partition 1 does not start on physical sector boundary.
/dev/sda5            2048  1953521663   976759808   83  Linux

WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util fdisk doesn't support GPT. Use GNU Parted.


Disk /dev/sdb: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1   250069679   125034839+  ee  GPT  

sudo parted -l  
Model: ATA WDC WD10EZEX-00K (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      1048kB  1000GB  1000GB  extended               boot
 5      1049kB  1000GB  1000GB  logical   ext4


Model: ATA TS128GSSD340 (scsi)
Disk /dev/sdb: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size    File system     Name  Flags
 1      1049kB  100GB  100GB   ext4
 2      100GB   128GB  28.0GB  linux-swap(v1)


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: Can't have a partition outside the disk!                           

Next this is what I typed into the terminal:

sudo mount /dev/sdb1 /home/ubuntu/temp/
sudo grub-install --root-directory=/home/ubuntu/temp/ /dev/sdb1  
Installing for i386-pc platform.
grub-install: warning: File system `ext2' doesn't support embedding.
grub-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub-install: error: will not proceed with blocklists.
  • 5
    Possible duplicate of How can I repair grub? (How to get Ubuntu back after installing Windows?) – try one of the manual methods. For whatever reason BootRepair both detects and later doesn't detect an existing Grub installation on your hard drive and doesn't offer to repair it. – David Foerster May 25 '16 at 11:16
  • Okay... I fixed it with the above. Apparently I just needed to restart after the last bit. Thought I did that. Not sure if there is any thing I need to fix, but I think the original boot repair did it? I'm debating leaving or deleting this post - I'll leave it for others to decide. Thanks Hizqeel for editing my post. – Brian Bersbach May 25 '16 at 16:10
  • Duplicate as per comments above – Fabby Apr 18 '17 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.