0

I premise I'm new in the Linux world. I'm using Ubuntu 15.10 and want to connect to a VPN. I type this in the command line:

sudo openconnect --juniper vpn.unipi.it

I give it all the needed information and at the end of process, terminal says:

ESP session established with server

That is, I think, it suceeded in connecting to the VPN. The problem now is that browser and application continue to use my wi-fi connection (I know it because my IP address doesn't change) but I need the VPN one to do my work...

Is it possible I have to configure a VPN connection with network manager? How should I do?

1

2 Answers 2

0

If this is a cisco vpn you need vpnc. Simply installing vpnc gives you the client, which can be connected using terminal. If you want to integrate it with network manager you need the network-manager-vpnc package. This link explains the installation and set up of vpnc CISCO VPN configuration steps

0

You VPN connection works, but your IP won't change. (That's the "V" in VPN : Virtual...) The message states that the VPN Tunnel is open and working, but perhaps your routes are not set correctly so the VPN is not used for the Servers you are using?

Usually the VPN Server sends a list of routes to your client which tells your client which servers are in the VPN. If that's missing perhaps there are some more settings for your VPN that needs to be passed to your openconnect call?

Can you ask an admin of the vpn if there is some config for openconnect available?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.