14

I have installed Ubuntu 16.04 on my ASUS S200e laptop. Everything is working except the bluetooth - I cannot get my mouse connected.

When I try to open Blueman, I get:

"Bluez daemon not running"

When I run lspci -knn | grep Net -A2; lsusb output is:

02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: AzureWave BCM43142 802.11b/g/n [1a3b:2107]
    Kernel driver in use: wl
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 03eb:8417 Atmel Corp. 
Bus 001 Device 004: ID 04f2:b3d8 Chicony Electronics Co., Ltd 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
1
  • Please edit your question and add output of lspci -knn | grep Net -A2; lsusb terminal command.
    – Pilot6
    May 24, 2016 at 14:36

3 Answers 3

14

Depending exactly what the issue is, there are a bunch of options. Here are a few.

1. Start the bluetooth daemon

Go to your terminal and type :

sudo /etc/init.d/bluetooth start

2. Reinstall packages

If this doesn't work, go to your terminal and type :

sudo apt-get purge blueman bluez-utils bluez bluetooth
sudo apt-get install blueman bluez-utils bluez bluetooth

Then run :

sudo /etc/init.d/bluetooth start
13
  • 1
    ~$ sudo apt-get install blueman bluez-utils bluez bluetooth Reading package lists... Done Building dependency tree Reading state information... Done Package bluez-utils is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: bluez:i386 bluez E: Package 'bluez-utils' has no installation candidate
    – Paul
    May 24, 2016 at 12:29
  • 1
    Okay, repeat the commands without the bluez-utils.
    – anonymous2
    May 24, 2016 at 12:31
  • OK - now the blueman program runs, but the buttons are greyed out. When you click adapter/device - activate, nothing happens
    – Paul
    May 24, 2016 at 12:40
  • 1
    Do you have a bluetooth switch on your laptop? If so, try switching it off and then on again.
    – anonymous2
    May 24, 2016 at 12:57
  • 2
    Could also try running sudo rfkill unblock bluetooth.
    – anonymous2
    May 24, 2016 at 12:58
12

i did the purge command already mentioned:

sudo apt-get purge blueman bluez-utils bluez bluetooth

but modified the install command like below

sudo apt-get install blueman bluez:i386 bluetooth

My settings icon is now missing but when I searched for bluetooth it prompted me to enable it and it now seems to work

I went back and reinstalled the other packages the purge removed:

sudo apt-get install pulseaudio-module-bluetooth* ubuntu-desktop* unity-control-center*

The abovecommand reinstalled the settings that had been uninstalled but bluetooth not connecting to my device. To be continued...

5
  • This post helped me resolve the last part askubuntu.com/questions/801404/…
    – bicepjai
    Dec 22, 2016 at 10:35
  • wait, so, after the first part, bleutooth was working, but too much stuff was purged; and then, when you reinstalled that stuff, it broke again?
    – Kyle Baker
    Feb 26, 2017 at 20:08
  • I ended up getting it working but the lag in sound vs video made it pointless. I put it out of my mind after that so I cant offer any further info... Feb 26, 2017 at 23:38
  • 1
    I got my Microsoft designer keyboard and mouse working wonderfully on Ubuntu 16.04 running on an Asus Vivobook. See my answer here: askubuntu.com/a/1023532/815371 (hope this helps someone)
    – Dagmar
    Apr 10, 2018 at 6:50
  • Works great. ty!! Feb 23, 2019 at 9:02
0

just replace the bluez-utils with bluez:i386 like so $sudo apt-get install blueman bluez:i386 bluetooth after then run the launch $sudo /etc/init.d/bluetooth start (Then it'll read out)

[ ok ] Starting bluetooth (via systemctl): bluetooth.service.

if you still don't see your device in the bluetooth pairing settings then your device's architecture just isn't built with the bluetooth setting available

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .