0

first timer here. Checked the documentation, don't see a solution. I'm a casual *nix user but I can follow your commands.

--

I am having trouble installing for a dual-boot Windows 10 and Ubuntu 16.04 LTS. The Live USB works perfectly (no flicker, wi-fi out of the box, scales the QHD beautifully). I'm sold. But, Ubuntu can't see the SSD during installation? gparted also doesn't detect it. Tried the Windows partition to free up space, didn't detect that either.

Ideally it will dual boot with Windows - probably on a fresh install since windows insists on taking 50% of the 500GB drive for it's own partition system (any thoughts? same issue?). Can't even get Windows to reinstall itself with a format option.. only these newfangled "reinstall" options.

System is a Dell XPS 9350.

Thank you!

  • Kernel 4.6 has Dell & Alienware improvements including 9350 phoronix.com/… You may want to add ppa to update to very newest kernel when released. Similar model? Ubuntu 16.04 on Dell Xps 15 9550 (i7-6700HQ - 1TB SSD - UHD 4k touch) ubuntuforums.org/showthread.php?t=2317843 Dell Xps 15 9550 Ubuntu 15.10 on new Infinity display (i7 6gen 16gbr UHD 4k touch) post 272 says 16.04 good ubuntuforums.org/showthread.php?t=2301071 Is drive new NMVe type? – oldfred May 24 '16 at 3:50
  • @oldfred yes, it is! – Gryph May 24 '16 at 11:36
  • for gparted to see NVMe drives is must the newest copy. Download directly from gparted as an ISO live system. gparted should be at least version 0.24.0-1 to recognize NVMe devices gparted.sourceforge.net/index.php Do you have the lastest update to UEFI from Dell? – oldfred May 24 '16 at 13:52
  • ok, will try once I can get to this point. Currently I am locked out by switching to AHCI in bios. – Gryph May 25 '16 at 4:39
0

According this page http://en.community.dell.com/techcenter/os-applications/f/4613/t/19679184, you have to change the IRST(Intel Rapid Storage Technology) mode to "AHCI mode" in your BIOS. With this mode, the SSD driver should be visible.

  • Great - if this works, would it be best practice to go (live usb) gparted -> wipe the drive -> partition for linux and windows -> install windows -> install ubuntu? I'm reading conflicting reports on that (and secure boot but that's another matter). – Gryph May 24 '16 at 12:51
  • This was a good suggestion but did not work (DO NOT FOLLOW) - now the system refuses to start fully, it doesn't get to the dell splash to enter bios - it's not quite a brick, the keyboard backlight/display backlight turns on and off repeatedly. Could be because it's the latest bios and the reference post is for an older bios? No idea how to get back to BIOS to change, not recognizing command (f12) – Gryph May 25 '16 at 4:34
  • That is usually another setting in UEFI called fast boot which is different than Windows fast start up. Fast boot assumes no system changes, so UEFI does not scan system for changes & in effect uses previously stored hardware configuration on drive. But then boot is too fast to get into UEFI from keyboard. They assume you boot into Windows and use the Windows way to get into UEFI. Some can just do a cold, full power down & even remove battery. Hold power switch for 10 sec to drain power. Then press correct key as soon as possible. Others have jumper pins on motherboard or remove MB battery. – oldfred May 25 '16 at 14:10
  • Tried power down - no luck. I would prefer to not remove MB battery as its a new system (would need to check ifixit for tamper issues)... Really surprised this was the result. Opening a new issue to try to resolve this, before initiating a return.. :( Thanks for your help. – Gryph May 25 '16 at 23:20
0

The answer to this scenario was to (sorry #'d steps causes spam error?):

  • Reset BIOS from AHCI problem by disconnecting battery as @oldfred mentioned. Search "dell 9350 service manual" -can't post link due to low rep :() ; note that there are clips attaching the case, and also the screw in the middle by service tag. Disconnect both CMOS and main battery, then power cycle. This resets bios.

SEGWAY - use Windows to download windows 10 USB installer via (https://www.microsoft.com/en-us/software-download/windows10ISO). A RECOVERY USB will not work in my experience - it will only reinstall windows without letting you determine partition size!

Go to Dell's site and d/l the wireless drivers. They won't come with the new windows install. http://www.dell.com/support/home/us/en/19/product-support/product/xps-13-9350-laptop/drivers

  • Turn off secure boot, and switch to AHCI in BIOS settings (this is via f12 during boot on my 9350 system). I don't know why the secure boot is an issue (as it's supposed to work), but it is, for me at least.

  • Boot live usb, run gparted, destroy main windows partition (Keep in mind this is only necessary if you desire a hard drive setup that is less than 50% windows - windows itself will not let you resize the partition to less than this in my experience).

  • Shut down, then insert your aforementioned windows 10 install media, install new windows, which will let you pick your partition size (tho' this may work without step using ubuntu to destroy the original, this is how I did it). I picked 70GB, since I am keeping it only to update bios or for emergencies (VM otherwise is better, I think). Stated minimum is 20GB, but already I am seeing 21GB taken by the system, so keep that in mind.

  • Finish install, then use those dell drivers I mentioned to get your wireless back. Run all your updates, set it up as you want, yak yak yak.

  • Shut down, go back to live Ubuntu USB, and install Ubuntu in remaining space (~375GB on this system)!

  • You'll likely want to scale the display for QHD, do this in display settings (hit windows key, type display).

  • Enjoy your clean ubuntu/windows 10 dual boot on the dell 9350! So far I have no significant odd issues on 16.04 LTS - the touch seems to not work when coming from suspend (I think), but that's for another post. Everything else is great - go for it!

Thanks for all the help AskUbuntuers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.