I want to make the switch to Antergos. When opening Unetbootin, I can't seem to open it successfully.

Here is what happens when I open UNetbootin from Terminal

namehidden@lolllll:~$ sudo unetbootin
[sudo] password for namehidden: 
X Error: BadAccess (attempt to access private resource denied) 10
  Extension:    130 (MIT-SHM)
  Minor opcode: 1 (X_ShmAttach)
  Resource id:  0x164
X Error: BadShmSeg (invalid shared segment parameter) 128
  Extension:    130 (MIT-SHM)
  Minor opcode: 5 (X_ShmCreatePixmap)
  Resource id:  0xc0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2800010
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2800010
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2800010

enter image description here

Is this a known issue? Can I fix this? Is there a workaround?

  • Did you open it from a terminal? What messages appeared there? – DK Bose May 24 '16 at 1:22
  • Is askubuntu.com/questions/775517/… of any help? – DK Bose May 24 '16 at 3:50
  • ok edited! the other comment didnt help because those commands ugrade the system. they dont fix the blank box @DKBose – lolreppeatlol May 24 '16 at 11:06
  • @lolreppeatlol, Avoid using sudo with graphic tools, you could use gksu, see why here. Could you post output of ls -l .Xauthority and which unetbootin – user.dz May 26 '16 at 21:23
up vote 7 down vote accepted
+50

First uninstall your current version of unetbootin, then use official unetbootin page to install using ppa instead of deb files. If fails then try opening it from launcher instead of terminal.

  • Wow, it worked! Should have thought of that. :P Thanks. I'll give the bounty later when possible. – lolreppeatlol May 26 '16 at 22:49
  • OK! no problem. – Cruelplatypus67 May 27 '16 at 3:50
  • 2
    I try in ubuntu 18.04 LTS, but not works. – alhelal Jul 12 at 6:58

This is a known issue.

As a workaround that does not require reinstalling unetbootin, you can run this command:

sudo QT_X11_NO_MITSHM=1 unetbootin

What the above command does is disable shared memory access for running this Qt based application, allowing it to work properly on GNOME.

The PPA source for unetbootin in the accepted answer includes the prefix to disable shared memory access in the default run command so that launching it from the GUI shortcut just works without any hassle: https://launchpad.net/~gezakovacs/+archive/ubuntu/ppa

Source of answer: https://github.com/unetbootin/unetbootin/issues/67

  • 1
    QT_X11_NO_MITSHM didn't work for me (on ArchLinux). However, knowing the problem is with X11 extensions, I solved the problem by "ssh -Y localhost" as a tunneled X11 connection doesn't support them. – André van Schoubroeck May 12 '17 at 13:16
  • Interesting... Thanks for your comment, @the-it-philosopher. – PaulMEdwards May 12 '17 at 18:22
  • 2
    This worked for me whereas the updating the PPA did not.. Thanks! – BillMan Jul 24 '17 at 16:54
  • 1
    Installed from the PPA, got the grey screen, but this works. 18.04 desktop. – Thufir Jun 10 at 5:30
  • 1
    This should be the accepted answer. – Ivan Ivković Oct 27 at 12:40

I changed the Exec property in unetbootin.desktop:

Exec=/usr/bin/xdg-su -c /usr/bin/unetbootin

and created file /usr/bin/unetbootin with the bash script:

#!/bin/bash
QT_X11_NO_MITSHM=1 /usr/sbin/unetbootin

then made it exetutable:

sudo chmod +x /usr/sbin/unetbootin

and now when I run Unetbootin from my application overview it launches normally with GUI.

  • But the file /usr/bin/unetbootin already exists, that is the binary, there seems something mixed up here. Own files should reside under /usr/local/sbin – rubo77 Feb 15 at 9:36

Under Ubuntu 17.10 with wayland, the x server is the program that manages access to the graphic devices drivers, xhosts allows users to connect to those drivers.

since sudo doesn't have an active session nor it's allow to access the server, unetbootin cannot create an instance of it's GUI

once you run that you give sudo access to the device drivers and hence allow unetbootin (since it's running as sudo) to create a window with nthose steps:

  1. under user run

    xhost local:root
    

    non-network local connections being added to access control list

  2. then with sudo

    sudo QT_X11_NO_MITSHM=1 /usr/bin/unetbootin 
    

Source: https://github.com/unetbootin/unetbootin/issues/94

So you can add an alias to your ~/.bashrcfile:

 alias unetbootin="xhost local:root && sudo QT_X11_NO_MITSHM=1 unetbootin"

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.