I want to make the switch to Antergos. When opening Unetbootin, I can't open it successfully.

Here is what happens when I open UNetbootin from Terminal:

$ sudo unetbootin
X Error: BadAccess (attempt to access private resource denied) 10
  Extension:    130 (MIT-SHM)
  Minor opcode: 1 (X_ShmAttach)
  Resource id:  0x164
X Error: BadShmSeg (invalid shared segment parameter) 128
  Extension:    130 (MIT-SHM)
  Minor opcode: 5 (X_ShmCreatePixmap)
  Resource id:  0xc0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2800010
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2800010
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x2800010

enter image description here

Is this a known issue? Can I fix this? Is there a workaround?

  • Did you open it from a terminal? What messages appeared there?
    – DK Bose
    Commented May 24, 2016 at 1:22
  • Is askubuntu.com/questions/775517/… of any help?
    – DK Bose
    Commented May 24, 2016 at 3:50
  • ok edited! the other comment didnt help because those commands ugrade the system. they dont fix the blank box @DKBose Commented May 24, 2016 at 11:06
  • @lolreppeatlol, Avoid using sudo with graphic tools, you could use gksu, see why here. Could you post output of ls -l .Xauthority and which unetbootin
    – user.dz
    Commented May 26, 2016 at 21:23

6 Answers 6


This is a known issue.

As a workaround that does not require reinstalling unetbootin, you can run this command:

sudo QT_X11_NO_MITSHM=1 unetbootin

What the above command does is disable shared memory access for running this Qt based application, allowing it to work properly on GNOME.

The PPA source for unetbootin in the accepted answer includes the prefix to disable shared memory access in the default run command so that launching it from the GUI shortcut just works without any hassle: https://launchpad.net/~gezakovacs/+archive/ubuntu/ppa

Source of answer: https://github.com/unetbootin/unetbootin/issues/67

  • 2
    QT_X11_NO_MITSHM didn't work for me (on ArchLinux). However, knowing the problem is with X11 extensions, I solved the problem by "ssh -Y localhost" as a tunneled X11 connection doesn't support them. Commented May 12, 2017 at 13:16
  • Interesting... Thanks for your comment, @the-it-philosopher. Commented May 12, 2017 at 18:22
  • 2
    This worked for me whereas the updating the PPA did not.. Thanks!
    – BillMan
    Commented Jul 24, 2017 at 16:54
  • 3
    Installed from the PPA, got the grey screen, but this works. 18.04 desktop.
    – Thufir
    Commented Jun 10, 2018 at 5:30
  • 3
    This should be the accepted answer. Commented Oct 27, 2018 at 12:40

First uninstall your current version of unetbootin, then use official unetbootin page to install using ppa instead of deb files. If fails then try opening it from launcher instead of terminal.

  • Wow, it worked! Should have thought of that. :P Thanks. I'll give the bounty later when possible. Commented May 26, 2016 at 22:49
  • OK! no problem. Commented May 27, 2016 at 3:50
  • 2
    I try in ubuntu 18.04 LTS, but not works.
    – alhelal
    Commented Jul 12, 2018 at 6:58
  • this answer would be improved by adding how to uninstall your current version of unetbootin
    – S.A.
    Commented Jan 18, 2019 at 10:41

I changed the Exec property in unetbootin.desktop:

Exec=/usr/bin/xdg-su -c /usr/bin/unetbootin

and created file /usr/bin/unetbootin with the bash script:

QT_X11_NO_MITSHM=1 /usr/sbin/unetbootin

then made it exetutable:

sudo chmod +x /usr/sbin/unetbootin

and now when I run Unetbootin from my application overview it launches normally with GUI.

  • But the file /usr/bin/unetbootin already exists, that is the binary, there seems something mixed up here. Own files should reside under /usr/local/sbin
    – rubo77
    Commented Feb 15, 2018 at 9:36

Since Ubuntu 17.10 wayland is the default x server, the program that manages access to the graphic devices drivers, xhosts allows users to connect to those drivers.

Since sudo doesn't have an active session nor it's allow to access the server, unetbootin cannot create an instance of it's GUI.

Once you run that you give sudo access to the device drivers and hence allow unetbootin (since it's running as sudo) to create a window with nthose steps:

  1. Under user run

    xhost local:root

    non-network local connections being added to access control list

  2. Then with sudo

    sudo QT_X11_NO_MITSHM=1 /usr/bin/unetbootin 

Source: https://github.com/unetbootin/unetbootin/issues/94

So you can add an alias to your ~/.bashrc file:

 alias unetbootin="xhost local:root && sudo QT_X11_NO_MITSHM=1 unetbootin"
  • thx - this worked for me under ubuntu 18.04 deb and ppa did not
    – Aveesh
    Commented Jan 6, 2019 at 18:48

Tried the accepted answer above but still had blank screen on Ubuntu 18.04

What I discovered: As part of the messages in terminal from sudo apt-get install unetbootin I saw the following:

Reading package lists... 
Suggested packages:
Recommended packages:
  gksu | kdesudo

My solution: Install gksu

sudo add-apt-repository ppa:belin/stable
sudo apt install gksu
sudo apt update
sudo apt upgrade

Vouila: Fully functioning UNetbootin screen & app

Fullly functioning UNetbootin screen

Warning?: I don't know if I understand all the ramifications of installing gksu. There seemed to be MANY update and upgrade dependencies when I installed gksu (all handled nicely by apt). The only thing I've noticed so far since installing gksu is my message windows changed a bit (they look better to me).


I had to create an USB pendrive on Ubuntu 18.04 for Windows 10 install and it needs NTFS, but unetbootin GUI can not list NTFS partitions, so I had to use unetbootin with command line.

xhost local:root

sudo QT_X11_NO_MITSHM=1 /usr/bin/unetbootin installtype=USB targetdrive=/dev/sdb method=diskimage isofile=/home/peter/Downloads/Win10_2004_Hungarian_x64.iso autoinstall=yes

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .