I need help on this.

I want to try using Ubuntu so I downloaded the 11.10 version over the net.

Well after the installation my desktop, I have run the the additional drivers. It installed about 70+ items I think and after a while a window pops up and asks me about the radeon driver, something about the 2 options, the propriety drivers I think.

I tried installing the 1st one but I got an error, and I tried the 2nd one and I installed it. After installation it asked me to restart. After I restart, I cant see the Ubuntu interface anymore. All I get to see is a black screen with a message moving around saying:

Input Not Supported.

So can I ask how can I install the graphics driver for my PC? I want the cool effect of Ubuntu.

I'm a super newbie in using Ubuntu so please bear with me:)

  • The exact same thing happens to me. :( Same card.
    – Apache
    Nov 27, 2011 at 16:20

4 Answers 4


The Input Not Supported message is most likely from your monitor indicating that the computer is trying to feed it an image which it can't decode. In most cases this means the resolution is too high, though in some cases it's the refresh rate. You should use the shell (Press CTRL+ALT+F1 to get there) to reset the resolution to 1024x768 60Hz. From there you can try increasing your resolution again until it stops working and then go back one. If 1024x768 still doesn't do it, you can try 800x600 60hz, but that's unlikely to be necessary.

Unfortunately I can't give ubuntu related details, but I found a page which should help you. Also of note: To get back to the GUI desktop after you've reset your resolution, use CTRL+ALT+F7.

The page I mentioned: https://wiki.ubuntu.com/X/Config/Resolution#Resetting_an_out-of-range_resolution


First of all, uninstall the proprietary driver to see a desktop again. Press ALT+CTRL+F1, login and type following commands:

  • Removing proprietary driver

    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
  • Install open-source driver again

    sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
    sudo apt-get install xserver-xorg-video-ati
    sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
    sudo rm -rf /etc/ati

If you receive: "$ E: Internal Error, No file name for libgl1-mesa-dri..."

Change third command above so:

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core
  • Now reboot your computer with:

    sudo shutdown -r now

Now your default open-source driver will be used.

To install newest Catalyst driver, following this step-by-step guide from here:


  • This didn't work. When I start to build a package for Oneiric, I get an error. :(
    – Apache
    Nov 28, 2011 at 18:05

A workaround is to run (adjust paths accordingly)

ln -s /lib/modules/3.9.0/build/include/generated/uapi/linux/version.h /lib/modules/3.9.0/build/include/linux/version.h


  • Welcome to Ask Ubuntu! ;-) Could you please review my edits and also review the editing help to improve the readability of your answers in the future... ;-)
    – Fabby
    Mar 24, 2015 at 23:27

Mmm... Your problem is very strange, probably you need to reinstall the Ubuntu installation, you can try to enter in text-console (like recovery) mode, selecting it on the grub options (options displayed at the start after boot Ubuntu) and if this work, you most log in specifying your username and password, next tray to download the official driver, typing the next commands:


wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-9-x86.x86_64.run
sudo chmod +x ati-driver-installer-11-9-x86.x86_64.run
sudo ati-driver-installer-11-9-x86.x86_64.run

If this not work, you must reinstall Ubuntu completely, and before to logged in, download and install manually the package described up (driver).

  • 1
    This guide to install proprietary driver is not correct and can cause errors. Simply reinstall is not a solution and would lead to the same error as above described. Nov 9, 2011 at 23:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .