The NTFS Write capabilities were removed in Ubuntu 11.10.
Henceforth, I cannot write/delete on my External NTFS hard drive, neither can I on the NTFS partition hosting MS Windows.

I tried to install NTFS-config (and adding the command sudo mkdir -p /etc/hal/fdi/policy to make it work) but before installing it, it asks for removing these packages to resolve dependencies, so what the heck?
Is there any other way to write on NTFS partitions in Ubuntu 11.10? Which can be installed smoothly.

Remove the following packages:                       
1)       flashplugin-downloader                             
2)       flashplugin-installer                              
3)       libasound2                                         
4)       libasound2-plugins                                 
5)       libasyncns0                                        
6)       libatk1.0-0                                        
7)       libaudio2                                          
8)       libavahi-client3                                   
9)       libavahi-common3                                   
10)      libc6                                              
11)      libcairo2                                          
12)      libcomerr2                                         
13)      libcups2                                           
14)      libcurl3                                           
15)      libdatrie1                                         
16)      libdb5.1                                           
17)      libdbus-1-3                                        
18)      libdbusmenu-qt2                                    
19)      libexpat1                                          
20)      libffi6                                            
21)      libflac8                                           
22)      libfontconfig1                                     
23)      libfreetype6                                       
24)      libgcc1                                            
25)      libgcrypt11                                        
26)      libgdk-pixbuf2.0-0                                 
27)      libglib2.0-0                                       
28)      libgnutls26                                        
29)      libgpg-error0                                      
30)      libgssapi-krb5-2                                   
31)      libgtk2.0-0                                        
32)      libice6                                            
33)      libidn11                                           
34)      libjack-jackd2-0                                   
35)      libjasper1                                         
36)      libjpeg62                                          
37)      libjson0                                           
38)      libk5crypto3                                       
39)      libkeyutils1                                       
40)      libkrb5-3                                          
41)      libkrb5support0                                    
42)      liblcms1                                           
43)      libldap-2.4-2                                      
44)      libmng1                                            
45)      libnspr4                                           
46)      libnspr4-0d                                        
47)      libnss3                                            
48)      libnss3-1d                                         
49)      libogg0                                            
50)      libpango1.0-0                                      
51)      libpcre3                                           
52)      libpixman-1-0                                      
53)      libpng12-0                                         
54)      libpulse0                                          
55)      libqt4-dbus                                        
56)      libqt4-declarative                                 
57)      libqt4-network                                     
58)      libqt4-script                                      
59)      libqt4-sql                                         
60)      libqt4-xml                                         
61)      libqt4-xmlpatterns                                 
62)      libqtcore4                                         
63)      libqtgui4                                          
64)      librtmp0                                           
65)      libsamplerate0                                     
66)      libsasl2-2                                         
67)      libsasl2-modules                                   
68)      libselinux1                                        
69)      libsm6                                             
70)      libsndfile1                                        
71)      libspeexdsp1                                       
72)      libsqlite3-0                                       
73)      libssl1.0.0                                        
74)      libstdc++6                                         
75)      libtasn1-3                                         
76)      libthai0                                           
77)      libtiff4                                           
78)      libuuid1                                           
79)      libvorbis0a                                        
80)      libvorbisenc2                                      
81)      libwrap0                                           
82)      libx11-6                                           
83)      libxau6                                            
84)      libxcb-render0                                     
85)      libxcb-shm0                                        
86)      libxcb1                                            
87)      libxcomposite1                                     
88)      libxcursor1                                        
89)      libxdamage1                                        
90)      libxdmcp6                                          
91)      libxext6                                           
92)      libxfixes3                                         
93)      libxft2                                            
94)      libxi6                                             
95)      libxinerama1                                       
96)      libxrandr2                                         
97)      libxrender1                                        
98)      libxss1                                            
99)      libxt6                                             
100)     libxv1                                             
101)     nspluginviewer                                     
102)     nspluginwrapper                                    
103)     skype                                              
104)     sni-qt                                             
105)     zlib1g

Thanks in advance

  • 1
    There is a reference for the sentence "The NTFS Write capabilities were removed in Ubuntu 11.10.", or is it only your negative experience?
    – enzotib
    Nov 9 '11 at 21:28
  • It is just a reference! No negative experience at all! I am enjoying 11.10.
    – Hanynowsky
    Nov 10 '11 at 2:13
  • What's the actual reference for your claim that NTFS write support was removed? I see nothing in the release notes, and searching on Google shows nothing relevant. Jul 3 '12 at 19:35
  • NTFS write support was not removed in Ubuntu 11.10. I am running Ubuntu 11.10 right now, I have not done any customization to ntfs-3g's configuration, and I can write to NTFS partitions just fine. Aug 22 '12 at 7:40

You need ntfs-3g to mount ntfs devices. That said, ntfs-config is only needed to configure ntfs in fstab wich I had problems with in the last upgrade. So install the first one and edit the fstab manually. A normal line to mount a ntfs disk in the boot will look like this in /etc/fstab:

/dev/sda4 /media/windows ntfs-3g defaults,locale=ca_ES.UTF-8 0 0


  • sda4 is the ntfs partition (the number might change in your case),
  • /media/windows is the directory where you want it mounted (must be created manually) and
  • locale must be your language (mine is catalan) because the system uses for reading the names of files and folders.

In your case i asume must be en_GB or en_US if you're english.

If you skip the fstab edit you can still use the ntfs partition as a user, just mount it by clicking in nautilus. But it will be mounted as user. With the fstab it's mounted by the system itself (with read/write to all so you can store your data, of course).

Wish it helps, good luck!

  • 1
    Yeah Thanks, I figured out that the problem came from using sudo aptitude instead of sudo apt-get. (I guess I need to dig to see what are the real differences between the two). When I tried with sudo apt-get install ntfs-config it asked to install ntfs-3g and some python staff and everything went smoothly. Thanks again, your answer helped ;)
    – Hanynowsky
    Nov 10 '11 at 2:16
  • 2
    There is an open bug for aptitude behaving strangely: bugs.launchpad.net/ubuntu/+source/aptitude/+bug/831768 - and also see: askubuntu.com/questions/78639/…
    – Caesium
    Nov 22 '11 at 16:45

There is simple way to enable NTFS-write by default: - first install the ntfs configs using terminal command:

sudo apt-get install ntfs-config

if apt not work try using aptitude

  • then you just do this command to enable ntfs-config by default

    sudo mkdir -p /etc/hal/fdi/policy

and last, try to mount the ntfs drive and paste some file to it from the ubuntu and the write function is usable now.

  • Thanks! Though this is not an answer to the question (Bug with APTITUDE). This is what I did at the first place, installing ntfs config and then make a directory... Then use dynamic mounting instead of static for external NTFS drives.
    – Hanynowsky
    Nov 22 '11 at 20:06

It is easier just to install ntfs-3g (it will remove ntfs-progs) and you will r/w support for ntfs drives. I had the same issue and it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.