2

I'm building a server to be deployed on a KVM host in the near future. I'm building the machine on my personal laptop in KVM using the virt-manager GUI for KVM. To begin with I kept most of the default values including using a NAT adapter creating it's own network for host/guest communication. If I change this setting to a bridged adapter, the Ubuntu Server guest fails to configure the network on boot and I get the "Waiting up to 60 more seconds for network configuration" message. What would be the best way to get the guest to work with the bridged adapter?

1

When I build my VMs in KVM, I use VMM (Virtual Machine Manager) it is in the Ubuntu software app, you connect to the VMhost via SSH, the only gotchas are you will want to also install Ask Pass as well, anyway, after running through all the configurations Disk size, memory etc, right before you start the VM for the first time there is a check-box that allows you to configure more settings, and below that there is a drop down for the network, I choose bridged from there.

The one gotcha to Bridged Networks and this is documented all over is that it does not work with Wireless network cards.

That being said if you are building your VMs on your laptop, are you using a wired connection or wireless. here is a link discussing the issue:

https://help.ubuntu.com/community/KVM/Networking

I hope this helps. Chris

  • Thanks, I was trying to bridge the adapter to wlan0. It works fine when I use eth0. – Jake Charman May 25 '16 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.