From this answer I learned previously how to disable the Firefox cache completely, however I have found that in the latest version (don't know when this change was made, but I think rather recently) the network.http.use-cache section is not in about:config so how can I now properly disable the cache? Has it simply changed its name or is this no longer possible or...? I am running Ubuntu GNOME 15.10 with GNOME 3.18 and Firefox 46.0.1.

up vote 8 down vote accepted

This option was actually removed in Firefox 43 because it caused this bug.

But there are still the following options available through the about:config section:

  • browser.cache.disk.enable (The disk cache is used in normal mode (non Private Browsing mode) and stores persistent data on the hard drive.)
  • browser.cache.memory.enable (The memory cache is used in normal mode and in Private Browsing mode and is purged when you close Firefox.)

The first should be what you want. It is inadvisable to also disable the second one though as Firefox needs some sort of cache to function properly. Information taken from here.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.