3

In order to fix a sound issue, I'd completely removed all PulseAudio packages, which removed several additional packages which I hadn't kept track of.

I have since added back several packages that had depended upon some of the packages, such as xubuntu-desktop (yes, I'm using Xubuntu, not the default Ubuntu setup).

Unfortunately, this has broken my setup a little bit, in that on boot, my graphical desktop manager is not started automatically. (in this case, I'm using GDM, not LightDM)

I can switch to a virtual terminal (via Alt-F1), login, then launch GDM with the following command:

sudo service gdm start

But this doesn't solve the problem itself.

I've also discovered that GDM is being started upon boot, but it's also getting killed by something.

Any help you guys can give would be great, because this is getting beyond annoying.

3

Try this:

Ctrl+Alt+F1

sudo apt-get install -f -m --reinstall -u gdm

Meaning of the short options:

-f : fix broken

-m : fix missing

--reinstall : refresh archives to newest versions

Useful option:

-u : print out a list of all packages that are to be upgraded


Next:

sudo dpkg-reconfigure gdm

select GDM instead LightDM

Finally:

sudo reboot 

Enjoy!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.