2

yesterday I set up my PC with Kubuntu 16.04 and all went fine except that there is no sound via HDMI. So I asked Google what to do, but I didn't find a solution for the problem.

That's the current state:

The output of aplay -l is

**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: HDMI [HDA Intel HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 0/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 7: HDMI 1 [HDMI 1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: PCH [HDA Intel PCH], Gerät 0: ALC887-VD Analog [ALC887-VD Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

speaker-test -c 2 -r 48000 -D hw:0,3 shows:

Wiedergabe-Gerät ist hw:0,3                                                   
Stream-Parameter sind 48000 Hz, S16_LE, 2 Kanäle                
Verwende 16 Oktaven rosa Rauschen                                     
Fehler beim Öffnen des Gerätes: -16, Das Gerät oder die Ressource ist belegt

For non-german users: This means, that I can't use card 0, device 3 because it's busy.

When I run speaker-test -c 2 -r 48000 -D hw:0,7 I can hear the pink noise.

So I assume that there are some settings which have to be switched. But I don't know what and how. Can anybody help me? I'm grateful for any kind of hint!

Best regards Thomas

0

After updating to 16.04 I also had problems playing sound over HDMI. Up to now I had always been able to change the output with PulseAudio. Under 16.04 this option didn't appear anymore. After some clicking around I found a solution that makes this possible again. It's quite simple.

  • Click on the loudspeaker symbol in the lower right corner of the control bar.
  • Click on the settings icon in the upper right corner.
  • Click on Volume on the left.
  • Select the Advanced tab.
  • Here should be a built-in sound device out and a built-in sound device Analog Stereo Duplex.
  • Click on the button where it says Off.
  • Select an HDMI output.
  • Save.
  • Now the HDMI output appears at the Devices and there is once again in PulseAudio the button where you can adjust the output device.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.