0

I've recently become an Ubuntu convert from windows 10, and i've really loved it so far. It's really far better than windows for development and alot of other things I do regularly.

However, there are 2 problems that I cant seem to be able to solve. I have 2 card drives, a 128GB SSD, and a 1TB HDD. Previously, my windows will be installed on the SSD, and the various programs on the HDD. Initially, I reformatted my SSD, and installed Ubuntu 16.04 on it. Only after installing ubuntu, did i go and reformat the HDD Into NTFS. This has caused some issues.

1) I followed a few stack overflow guides, that told me i can still install programs on the HDD in ubuntu, just by finding where it's mounted and installing there. its mounted under

/media/wboy/HDD_NAME

I've installed dropbox, anaconda, and other stuff there, but i realise dropbox throws a "media directory changed, relink or exit" something error , and all my symlinks / programs are NOT accessible until i click the harddrive icon in the launcher to view that drive. Then magically the symlinks and stuff will work again. Is there a way to fix this? I dont want to have to click the drive in the launcher every time i restart my computer.

2) I dont know why whenever on load, it shows me a grub menu, i only have ubuntu installed. BUt the options are: ubuntu, ubuntu advanced options, memtestx86, some other memtest, and windows 10 loader (/dev/sda1). Why do i have a windows 10 loader? i clean installed ubuntu, there shouldnt be a loader! selecting the loader loads a blank screen which goes nowhere. I suspect i screwed up somewhere with LVM, but im not really sure.

Would appreciate any guidance from the awesome Ubuntu community!

Thank you so much for reading! :)

5
  • I wrote an answer for a similar issue you can check it out here. The settings with grub can be changed so it doesn't show the menu at boot time if you choose .. you need to edit the /etc/default/grub file and after you make the changes you need to runsudo update-grub or an easier way is to google Grub Customizer for a graphical interface.
    – John Orion
    May 23, 2016 at 17:38
  • The windows is probably because you have an UEFI which has a separate partition which keeps the boot information... its probably seeing that and trying to load that boot loader which has been uninstalled but the files still exist on the EFI partition... you don't really want to mess around with that .. just use the above to set it so the menu doesnt show
    – John Orion
    May 23, 2016 at 17:44
  • Hi John! thanks for your reply! But its occupying space, yes? typing sudo blkid gives me /dev/sda1: LABEL="System Reserved" UUID="F4FA9C6CFA9C2CBC" TYPE="ntfs" PARTUUID="2d2091d7-01". Is there a way to remove this and add the space to my drive?
    – Wboy
    May 24, 2016 at 14:00
  • @JohnOrion also, can you post your comment as an answer so i can accept it? :)
    – Wboy
    May 24, 2016 at 14:16
  • You can remove the system reserved partition but depending on how the disk is laid out it can be complicated as to moving the other partitions around and expanding the root partition to gain the space. It can be done but it can also cause complete destruction of the data and force a full reinstall if something isn't done right or an error occurs during the process. The recovery partition is only usually 450-500MB so you really wouldn't be gaining much for the amount of effort you would most likely need to apply.
    – John Orion
    May 24, 2016 at 14:56

3 Answers 3

0

I wrote an answer for a similar issue you can check it out here.

The settings with grub can be changed so it doesn't show the menu at boot time if you choose .. you need to edit the /etc/default/grub file and after you make the changes you need to run sudo update-grub or an easier way is to google Grub Customizer for a graphical interface.

6
  • Hey i just tried the hide grub method, but it doesnt seem to hide it :S
    – Wboy
    May 24, 2016 at 15:36
  • how did you try to hide the grub .. editing the grub file or with grub customizer?
    – John Orion
    May 24, 2016 at 17:26
  • edited /etc/default/grub with a text editor, then ran sudo update-grub. The menu still appears..
    – Wboy
    May 25, 2016 at 2:32
  • I would change /etc/default/grub as follows GRUB_HIDDEN_TIMEOUT="3" GRUB_HIDDEN_TIMEOUT_QUIET="true" GRUB_TIMEOUT="-1" that should boot you directly into Ubuntu but will have a 3 second delay so you can get to the menu if you need too
    – John Orion
    May 25, 2016 at 3:06
  • you may also need to add this at the end of the file GRUB_DISABLE_OS_PROBER="true" to keep grub from looking for other OS's
    – John Orion
    May 25, 2016 at 3:19
0

In answer to your first question: You can find out how to auto-mount NTFS partitions on boot here.

0
  • Open Disks utility in Ubuntu.
  • Go to the hard drive which you want to mount at your desired location.
  • Unmount the selected partition.
  • Open its settings and select 'Edit Mount Options...'
  • Then change the mount point to the location which you get after typing 'pwd' after manually mounting your hard drive.
  • Change the 'identify As' field to /dev/disk/by-label/Data (You may have something else but that won't matter much)
  • Save and Remount the hard drive and it will start mounting automatically.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .