I am running Ubuntu 16.04 (did a clean install of 16.04) on a Lenovo W540. The only important thing (hardware-wise) is that it has an intel CPU and Nvidia Quadro K2100M that supports prime.

I install nvidia-367 (This is from the new graphics drivers PPA and I have also tried several other versions, but 367 is just the newest) and reboot. Everything works perfectly if I don't have a monitor plugged in.

When I plug in an external monitor (using the DisplayPort port) my screen flickers and then I get an error from Ubuntu.

"unity-settings-daemon crashed with SIGABRT in g_assertion_message()"

I then try to open unity settings "Displays" panel. I get another crash and error: "unity-control-center crashed with SIGABRT in g_assertion_message()".

How would I go about debugging and solving this issue?

I have searched for this error in the ubuntu bugs and nothing stands out as the same issue as mine. https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1568440 is a little close but the stack trace is different.

Here is the stack trace top from the unity-control-center crash:

 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 gsd_rr_config_load_current () from /usr/lib/x86_64-linux-gnu/libunity-settings-daemon.so.1
 gsd_rr_config_new_current () from /usr/lib/x86_64-linux-gnu/libunity-settings-daemon.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/unity-control-center-1/panels/libdisplay.so

uname: Linux 4.4.0-22-generic-x86_64

How can I use my nvidia drivers and an external monitor at the same time?

Update: If I go into nvidia settings 'Prime Profiles' and use intel graphics instead of nvidia then everything works fine again. I just can't switch back to nvidia.

  • I think I'm seeing a very similar if not identical issue. This worked fine under 15.10. askubuntu.com/questions/789972/… – andyczerwonka Jun 22 '16 at 1:06
  • After reading your update, it's clear that this is the same issue. I have to run in Intel Graphics, just like you to get things working. Under NVidia, and only when another monitor is plugged into the DisplayPort, I get the same crash when trying to launch the Displays panel. – andyczerwonka Jun 22 '16 at 10:51

If you use optimus graphics, I suppose it depends on whether the display port is going through your intel graphics or on your nvidia graphics.

Does your external monitor work when you switch to the intel profile in nvidia-settings? if so, then the display port most probably runs through your intel graphics.

I am not sure whether bumblebee and primus still runs under ubuntu 16.04?

Bumblebee works similar as to how optimus graphics works on windows. your desktop would run on your intel graphics and only when you run a program by typing primus or optirun, it will run through nvidia graphics.

Please let me know whether you can get bumblebee to work.

installation instructions: https://wiki.ubuntu.com/Bumblebee#Installation

  • 1
    I thought bumblebee was being deprecated in favor of nvidia's prime stuff? Also, I used to be able to use the external monitor with nvidia drivers until recently (when I clean installed 16.04) – Ben Echols May 24 '16 at 17:05
  • I agree with @BenEchols comment above, this worked just fine for me prior to the upgrade. I'm guessing it's an NVidia/Kernel issue as I can't imagine anything else that would break so badly. – andyczerwonka Jun 22 '16 at 16:48
  • This issue was recently fixed for me (not sure if from kernel or nvidia or intel or ubuntu)... Hopefully it was resolved for you as well! – Ben Echols Feb 8 '17 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.