0

I have set local ubuntu 16.04 server yesterday. I configurated static IP and everything was good. I was able to connect to the server. Today I travelled to city, where i stydy. The server couldnt work becouse of diffrent router settings.

For the last few hours im trying to make it work again. My base system is Windows 10, then I have linux mint 17.3 on virtual machine. On linux i have ubuntu server. In both cases im using virtualbox to host VM's.

Output of ipconfig in Windows:

IPv4 Address 192.168.1.10
Subnet Mask 255.255.255.0
Default Gateway 192.168.1.1

I have two network adapters connected to ubuntu: Host-only and NAT.Host-only settings

Configuration of /etc/network/interfaces

auto lo
iface lo inet loopback
auto enp0s3
address 192.168.1.20
netmask 255.255.255.0
network 192.168.1.1
broadcast 192.168.1.255
auto enp0s8
iface enp0s8 inet dhcp

Ifconfig for enp0s3 show me:

inet addr: 192.168.1.20

Ubuntu server has internet connection(i can ping google.com) but i cant connect to local server. Would appreciate any kind of help.

0

I'd suggest changing the NAT adapter to a network bridge adapter. NAT means it is essentially using the IP of your host, which in this case is 192.168.1.10. From there, Virtualbox will act as a router.

Setting it to network bridge adapter will connect the virtual machine to your "real" network.

  • Thanks for quick anserw. Changing the second adapter to bridge or even disabling it doesnt make any diffrence. Can you advise me how should i configure my windows network adapter(ones that uses linux mint)? Atm i configured them as nat and host-only – Szymon Strzelka May 23 '16 at 16:36
  • I'm not entirely sure how your virtual machines are setup. Are you saying that you are two different physical machines? One with a Mint VM and one with an Ubuntu Server VM? – Bram Koert May 23 '16 at 17:26
  • I have one physical machine. Windows hosts linux, linux hosts ubuntu – Szymon Strzelka May 23 '16 at 17:27
  • Why are you using a VM inside of a VM? – Bram Koert May 23 '16 at 17:28
  • Because i set mint for my my colleague projects. Then i was force to set another machine to cooperete with mint – Szymon Strzelka May 23 '16 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.