I recently installed Ubuntu 16.04 alongside Windows 7 on my HP Envy m6-1125dx laptop and installed all available updates. It has a built-in wireless card (Ralink RT5390R 802.11b/g/n) and available networks are shown just fine. I can also choose a network and enter the password but after entering the password and confirming it the window just closes and nothing happens, not even an error message.

Wired connection works just fine and on Windows 7 I can connect to WiFi without any problems. I looked for drivers but they are only offered for Windows.

Is there any way to fix this or does the wireless card just not work on Ubuntu? Thanks in advance for any help, I'm fairly new to Linux.

I ran the Wireless Info Script provided in the forums, you can find it here: http://pastebin.com/waNtrP5K

  • Is the router an a/b/g/n or ac router? – You'reAGitForNotUsingGit May 23 '16 at 12:32
  • @Android It's an ac router – Sven May 23 '16 at 13:19
  • What happens if you force the router to only operate in N mode? – You'reAGitForNotUsingGit May 23 '16 at 15:04
  • Your script says, " Selected IBSS BSSID <MAC 'giessen.freifunk.net' [AC5]> based on configured SSID" In the scan result, it appears as an adhoc connection without any encryption key. Is that what you intend? Please explain. – chili555 May 23 '16 at 18:22
  • @chili555 No, that's an open WiFi that I used to test the wireless card. It did connect to it but I couldn't open any site. When I want to connect to my router it doesn't do anything like I said in my post. – Sven May 24 '16 at 17:11

I was having similar problems. I was able to resolve it by going to the edit connection page for the connection in question and entering both the password and security type (WPA in my case) in the Wi-Fi Security tab.

You can access the edit connection page through the drop down on the Wi-Fi icon at the top of the desktop (after already having attempted to connect); or by clicking the orange arrow on the far right of that connection under the listing of wireless connections within the network manager.

| improve this answer | |


Can see routers SSID, But computer asks for a password again and again.

Computer has (b)/(g) wifi

Router has (n) Wifi

Router settings may be in Greenfield Mode.

Greenfield Mode BAD!

If you are having a problem connecting to your router, especially on an old computer that runs on (b) or (g) wifi, check to see if your routers radio settings are set to greenfield Mode. This mode will ignore all (b) and (g) wifi as noise and only work with (n) capable devices. It also is quite destructive, as it can "Shout over" (b) and (g) wifi signals, so enabling it is a bit of a bad neighbour move, even if all your devices support (n) wifi only.

The symptoms are similar to what is described by others on this topic, that being that you can see the SSID of your network, but it will just ask for a password again and again without an error.

| improve this answer | |
  • Wow, thanks! After reading this answer I found my router's (ASUS) equivalent, "Wireless Mode" which I changed from "Auto" to "Legacy". This fixed my connection issues with an old B/G client. – Liedman Jul 28 '19 at 9:49

I experienced the same issue in Ubuntu 16.04 and Linux Mint 18.

What I suggest to you is to follow these steps:

  • go to Network Settings
  • choose the network you are trying to connect to
  • under the security tab, enter the wifi password manually
  • save it

You are not the only one impacted. I wrote about it here and you can see that multiple have been affected by it, even the Arch Linux users.

| improve this answer | |

I had the same problem and fixed it:

clicked the connection symbol in the top bar

edit connections > select the wifi > edit > wifi security > typed the key > in authentication changed to shared key option.

| improve this answer | |

I had similar issues on Ubuntu 18.04, and I think for me the reason was that the default key chain was not unlocked yet. The (admittedly somewhat quirky) solution for me was to open the browser which opened a prompt for unlocking the keychain and then after unlocking try connecting again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.