1

I want to remove win 8 and install Ubuntu 16.04 64bit on a Samsung laptop with UEFI. I'm not interested in a dual boot setup.

With the intention of changing the boot order so that I can boot from a USB drive, I swiped the top right screen corner (charm bar) in the win 8 start page, going to Settings>Power (shift clicking on Restart) >Troubleshoot>Advanced Options. However, there are no UEFI settings options on this page.

I would be most appreciative if anyone can offer any suggestions as to where to go from here.

2
  • Are you using Spanish version of Windows 8? Because it does not provide the option UEFI Firmware Settings. You may like to refer the following: askubuntu.com/questions/221835/… – Dhaval Simaria May 23 '16 at 9:26
  • 1
    Have you updated UEFI/BIOS to latest version from Samsung? What model Samsung? Many UEFI require Secure boot off, or turning on allow booting from external or flash drives. We also see many users after erasing Windows find one application or game that only works in Windows and want to reinstall it. Best to do full backup or just start with dual boot. – oldfred May 23 '16 at 13:12
2

If you have your bootable USB ready, you can set the boot order in your BIOS.

The difficulty could be accessing the BIOS. In theory, you should just have to shut down the laptop, press the power button and immediately start tapping the F2 key or maybe F12 or F10 to bring up the BIOS. However, you may run into problems. According to this site

By default, a Windows 8/8.1 shutdown is not a real shutdown. Instead, it is hybrid shutdown where contents of memory are saved to disk. This allows for a faster startup. However, turning on the PC after a hybrid shutdown does not allow for pressing F1 or F12 during startup.

There are several ways to enter Setup Utility (F1) or the Boot Menu (F12) on a Microsoft Windows 8/8.1 PC as explained below:

  • Press and hold the Shift key while selecting the Shutdown option in Windows 8. This will make the PC perform a full shutdown instead of a hybrid shutdown. Then F1 or F12 can be pressed successfully during startup.
  • Select Restart instead of Shutdown. Then F1 or F12 can be pressed successfully during startup.
  • Disable the fast startup option in Control Panel -> Hardware and Sound -> Power Options -> Choose what the power buttons do.

BIOS versions vary, but you should be able to find the boot order menu and figure out how to change it by looking around. Put USB at the top of the list, and with the USB inserted, save configuration and exit. Now the computer should try to boot again, and if the stars are in your favour if you got everything right and the USB you made is compatible then it will boot. Things to consider:

Try using Legacy Mode instead of UEFI if it is available; this seems to avoid problems for many devices.

You might have to disable secure boot, which has to be done in BIOS too. If Windows boots after the boot order has been set to boot USB first, try disabling secure boot.

If your laptop boots with 32-bit UEFI only (even for running a 64-bit OS) you will probably need to edit your USB

If these tips don't help, visit this well-maintained forum post for more troubleshooting

3
  • 1
    If you boot usb in legacy mode, it will install a legacy mode. I currently do this and avoid all secure boot problems. – Bhikkhu Subhuti May 23 '16 at 11:54
  • 1
    Simple and limited? My Asus has 10 pages of GUI UEFI stuff. Figuring that out was the hardest part of installing Ubuntu. – Organic Marble May 23 '16 at 12:55
  • 1
    Haha ok I edited. – Zanna May 23 '16 at 13:43
2

Disable hibernation and Fast startup in Windows - open command prompt as administrator and execute : powercfg /h off.

Open Windows Control Panel -> Power Settings -> uncheck Fast startup. In case it is not visible - enable show hidden settings.

Shutdown the machine completely, do NOT reboot. Start the computer, boot into the BIOS and select the USB entry with UEFI in front.

In case you still cannot boot from the USB drive, it may be configured not correctly. 3rd party tools often do not create the Ubuntu installation media properly. Use the diskpart tool from Windows, so open command prompt as administrator and execute the following commands :

diskpart
list disk  
select disk *  
clean  
create partition primary  
active  
format fs=fat32 quick  
assign letter=**  

Note : * = number of USB drive | ** = select a free drive letter

Mount the ISO file and copy the whole content to the USB drive. Now you should be able to boot from the USB drive, wipe the disk - you can either use GParted or the Ubuntu installer to do this - and install Ubuntu as the single operating system on the disk.

0

You need to run bios setup. There is a switch to turn on boot selection.. boot setup and order is one thing.. hitting another fkey to do boot selection is another. I usually have better luck doing that latter, but it must be enabled in bios. I bet this is something that will help you. My fkey is f2 for bios and f12 for boot selection on Acer. There is also a thing called set trusted source. This might also block you. You will likely need to add trusted source after you install ubuntu.

To do this on my Acer (before I killed uefi for legacy), I needed to set a password in security for bios. Then more options appeared. There you can logically work out how to set the secure boot file. My bios brought meto the directory to select the efi file. Good luck and remember to set the password back to "nothing" before you forget what the password was. This will nearly brick your laptop if you forget. Type your password very slowly and mindfully.

Since I had so many problems.. I went legacy. I am not sure what uefi really buys you since most people turn off secure boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.