2

I'm currently running Ubuntu 16.04 LTS on a MSI Dominator Laptop, and with the laptop screen disabled and only using my external monitor (LG 34UC88 @ 3440x1440 21:9) Ubuntu refuses to display across the entire monitor height. It displays across the full width of the monitor (3440 px) but only displays across the top 1080 px of the monitor, resulting in this:

enter image description here

I have an Nvidia GTX870M and Intel integrated graphics in the laptop with NVIDIA binary driver version 361.42 from the nvidia-361 repo.

Here is my xrandr -q output:

Screen 0: minimum 8 x 8, current 3440 x 1440, maximum 16384 x 16384
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 connected primary 3440x1440+0+0 (normal left inverted right x axis y axis) 800mm x 335mm
   3440x1440     59.97*+  49.99    29.99  
   2560x1080     60.00    59.94    50.00  
   1920x1080     60.00    59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      59.96  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  
eDP-1 connected
   1920x1080     60.02 +  59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
VGA-1 disconnected
  1680x1050 (0x47) 146.250MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock  65.29KHz
        v: height 1050 start 1053 end 1059 total 1089           clock  59.95Hz
  1280x1024 (0x4b) 108.000MHz +HSync +VSync
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
  1024x768 (0x52) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x59) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  640x480 (0x62) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz

and here is my current xorg.conf setup:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

Any help would be greatly appreciated. My next step would be getting it to display correctly when in a dual screen setup with the built-in laptop screen if you have any ideas about that also.

  • Why are you using an xorg.conf file? Have you created it on purpose? If not, have you tried renaming it to something else and reboot to let the system auto-detect your screen characteristics? – Stormlord May 25 '16 at 16:56
  • I use a similar setup that includes a 4k screen via display port and 4k screen on laptop (dell m3800) with optimus quadro + iris and i don't have this problem. I don't have an xorg.conf at all so that might be your problem that you are trying to use the nvidia directly which i don't think you need to do with a fully working optimus setup. I'm using the nvidia-364 from the graphics-drivers ppa which seems to be better at optimus for me than any of the others. launchpad.net/~graphics-drivers/+archive/ubuntu/ppa – Amias May 25 '16 at 16:59
  • @Stormlord I tried renaming it and rebooting, and another was created identical to the old one. Is there a way to turn it off, to where an xorg.conf file isn't used? – Max Samuels May 25 '16 at 17:27
  • Hmm. This is strange. If an xorg.conf is generated automatically in /etc/X11 even if you delete it, then the Nvidia driver is the only thing responsible I can think of but it's really strange indeed. – Stormlord May 25 '16 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.