I might have accidentaly purged some critical files, causing my Kubuntu 14.04 to not boot past the startup logo.

By entering the recovery mode from a LiveUSB, and running sudo apt-get install -f, I am told that there are some unmet dependencies. So I am guessing those are the files that I purged.

Is there a way of installing all crucial files in recovery mode to get Kubuntu to run smoothly again?

1 Answer 1


Try this:

Boot from liveUSB.

Open a terminal.

Determine your HDD system partition.

exec sudo -i
fdisk -l

Mount your HDD system partition. X is the drive letter. Y is the partition number. Substitute the correct partition like sda1, sdb5, etc. continue running:

mount /dev/sdXY /mnt

Example: mount /dev/sda5 /mnt

If you have a separate boot partition, mount your boot partition:

mount /dev/sdXY /mnt/boot

Example: mount /dev/sdb6 /mnt/boot

Mount the critical virtual filesystems:

for i in /dev /dev/pts /proc /sys /run; do mount -B $i /mnt$i; done

Chroot into your HDD system device:

chroot /mnt

Now reinstall kubuntu:

apt-get update
apt-get install --reinstall kubuntu-desktop
apt-get install -f
apt-get dist-upgrade

And reboot

  • thanks for your fast response. tried your method but could only get to the for i in /dev /dev/pts /proc /sys /run; do mount -B $i /mnt$i; done part. It gives me this error: mount: mount point /mnt/dev does not exist mount: mount point /mnt/dev/pts does not exist mount: mount point /mnt/proc does not exist mount: mount point /mnt/sys does not exist mount: mount point /mnt/run does not exist This is usually where all other methods I have tried failed, too. I dont know how to fix this. May 23, 2016 at 4:52
  • From running fdisk -l, I get this warning about the SSD that my system is on: WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted. May 23, 2016 at 5:01
  • ok I have tried your method again, with also enabling chroot to have internet access (without this, any updates could not be fetched): cp -L /etc/resolv.conf /mnt/etc/resolv.conf. Now when I try and run apt-get install --reinstall kubuntu-desktop, I get a list of packages with unmet dependencies (about 100 of them)?? And the message E: Unable to correct problems, you have held broken packages. Any suggestions how to fix this? May 23, 2016 at 10:23
  • You can get a list of actual held packages with: dpkg --get-selections | grep hold. And use apt-get to try to install held packages one on one apt-get install <packagename>
    – kyodake
    May 23, 2016 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.