This question already has an answer here:

This fault has only emerged since upgrading from Ubuntu 14.04.4 to 16.04. My laptop is an Acer Aspire E13, Intel Pentium N3540 no graphics card. I am duel booting this laptop, no issues with windows suggesting it is not a hardware issue.

Specifically the fault is a freeze of Ubuntu when using unity with no obvious trigger. Once frozen no response at all can be elicited.

I originally thought this may be a flash problem as I have in the past had similar problems with flash plugins and Ubuntu/other linux distros. However purging and reinstalling does not seem to improve the situation. I have also tried a number of different browsers in an attempt to see if this effects the frequency of the fault, it doesn't seem to. I also attempted turning off hardware acceleration again no fix.

The major issue I have is that the freeze is total, there is no way to move from tty7 (unity) to tty1-6 in an attempt to read the logs and because a forced shutdown is the only way to get a response I can find no record of the fault after restart.

How can I go about debugging this fault? Has anyone seen a similar fault and know the solution?

Thanks in advance

marked as duplicate by Zanna, Fabby, Eric Carvalho, waltinator, David Foerster Feb 1 '17 at 11:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Same description precisely applies to issues experienced with laptop Acer Aspire V11 Touch (V3-112P-P2E7) – XavierStuvw Oct 31 '16 at 8:58
  • I keep on experiencing these issues with the laptop Acer Aspire V11 Touch (V3-112P-P2E7) also after downgrading Ubuntu from 16.04 to 14.04. Linux kernel is 4.4.0-53-generic. Never ever experienced this on any of my desktops whether with 16 or 14. To which extent can the problem depend on the machine? – XavierStuvw Dec 9 '16 at 17:55
  • Continues: the computer that has never frozen comes with kernel 3.13.0-101-generic and Ubuntu 14.04. So there is a reason to link these freezes to a potential kernel problem (hints gathered from wiki.ubuntu.com/X/Troubleshooting/Freeze). Sure the Ubuntu release is not key in my experience, since upgrading/downgrading is immaterial. I would now blame either something in the drivers or in the kernel... – XavierStuvw Dec 9 '16 at 18:42
  • From my experience of looking through various reports of similar problems there seems to be a dependence on both machine and linux kernel. i.e. some machines only experience this fault with specific kernels. I have had a similar fault with a different machine (solved in the same way) running arch linux on a different kernel. See also Zanna comment for more info on which kernels are most likely to be effected – Jakob45 Jan 3 '17 at 22:04

Try this... it stopped the hangs with mine. I have the same set up as you.

sudo nano /etc/default/grub

Edit the following line:


Add intel_idle.max_cstate=1 to the other parameters.

  • 2
    Worked without replacing "quiet splash", I simply added it in after these two parameters. – Jakob45 May 24 '16 at 22:13
  • yeah you don't want to replace quiet and splash - unless you want to see process info at boot time instead of the splash screen – Zanna Sep 9 '16 at 21:37
  • This is not a solution for my case on an Acer Aspire V11 Touch (V3-112P-P2E7). The systems froze again on day 1 after applying the suggested change. What could be peculiar to the most recent usage is that I have suspended and resumed my sessions several times. – XavierStuvw Nov 1 '16 at 15:58
  • Addition to the comment above: the Linux kernel is 4.4.0-45-generic – XavierStuvw Nov 2 '16 at 8:20

I use Ubuntu-MATE 16.04 and I have freezes when i play dota 2 but I think this is a steam and radeon driver problem. About identifying the problem:

  • If it's an xorg problem the you can see the file ~/.xsession-errors or the file /var/log/Xorg.0.log as described here: Where is Xserver log file located?
  • There's also the application Logs from the package gnome-logs (I use the application Log File Viewer from the package mate-utils) to see various log files.
  • If you are suspicious what application causes the problem, for example firefox, then run in terminal firefox |tee firefox.txt and this will create a firefox.txt file at your home folder with the output of the command firefox, so even if your system freezes then you can read the file firefox.txt afterwards and see if there was an error.

Hope that helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.