1

I've installed theano on ubuntu 16.04. I can specify the installation procedure later if required

Some of the system specs are as follows

Ubuntu 16.04
CUDA 7.5
NVIDIA Drivers 361
Python 2.7

The installation seems to have gone ahead smoothly and the testing script here runs correctly and shows that the gpu is being used. After that I installed opencv as per the instructions given here. The site doesn't seem to be working right now so I'll list the instructions below

  1. git clone https://github.com/Itseez/opencv.git
  2. cd opencv && git checkout 3.1.0 && cd ~
  3. git clone https://github.com/Itseez/opencv_contrib.git
  4. cd opencv_contrib && git checkout 3.1.0 && cd ~
  5. cd opencv && mkdir build && cd build

  6. cmake
    -D CMAKE_BUILD_TYPE=RELEASE
    -D CMAKE_INSTALL_PREFIX=/usr/local
    -D INSTALL_C_EXAMPLES=OFF
    -D INSTALL_PYTHON_EXAMPLES=ON
    -D OPENCV_EXTRA_MODULES_PATH=~/opencv_contrib/modules
    -D BUILD_EXAMPLES=ON
    ..

  7. make -j4 && sudo make install && sudo ldconfig

After this, opencv is installed and runs fine.

However, after that, the initial theano setup does not work. When I run the gpu testing script above, I get the following error/warning

NVIDIA: no NVIDIA devices found
NVIDIA: no NVIDIA devices found
WARNING (theano.sandbox.cuda): CUDA is installed, but device gpu0 is not available  (error: Unable to get the number of gpus available: unknown error)

When I run nvidia-smi from the terminal, I get the following error

NVIDIA-SMI couldn't find libnvidia-ml.so library in your system. Please make sure that the NVIDIA Display Driver is properly installed and present in your system.
Please also try adding directory that contains libnvidia-ml.so to your system PATH.

(And neither does sudo nvidia-smi)

And when I run the deviceQuery script from the Cuda Samples, I get the following error

CUDA Device Query (Runtime API) version (CUDART static linking)

NVIDIA: no NVIDIA devices found
cudaGetDeviceCount returned 30
-> unknown error
 Result = FAIL

When I run nvcc -V , I get the expected output as follows

nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2015 NVIDIA Corporation
Built on Tue_Aug_11_14:27:32_CDT_2015
Cuda compilation tools, release 7.5, V7.5.17

Any suggestions as to what could be going wrong? If required I can specify further details. A few addditional details

a) I am not using bumblebee

b) Installed Nvidia drivers from the Additional Drivers section in the Ubuntu Settings. However I don't think this is an issue as the gpu testing script runs absolutely fine.

c) In the opencv installation, I haven't specified a flag to use cuda, but I can clearly remember that during the build process, there were certain files containing cuda in their name that were part of the build process.

Thanks in Advance.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.