1

I'm trying to play a video in an Ubuntu Touch QML app. The audio plays, but no video is shown.

A minimalistic version:

import QtQuick 2.4
import Ubuntu.Components 1.2
import QtMultimedia 5.5

MainView {
    applicationName: "untitled.username"
    Video {
        anchors.fill: parent
        source: "http://feeds.nos.nl/~r/journaal20uur/~3/JRJKV6kpvRc/mp4_web03.mp4"
        autoPlay: true
    }
}

This works as expected when deploying on the desktop (i.e. video is shown). But on a BQ Aquaris 10 tablet only the audio is played, but no video is shown. I've tried to play a WebM, and local stored file too, but same results.

The app has AppArmor's networking and video Security Policy Group set. I'm using framework ubuntu-sdk-15.04.5. My device is on the current OTA11 rc. Anything else I can try?

0

Answering my own question, it might be linked to this bug, which mentions problems streaming video over http. Indeed, if I store the mentioned file locally instead of streaming, it's shown correctly.

I guess the locally stored files I've tried earlier (WebM, Theora) might have other issues, but that seems unrelated to this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.