1

Is it possible to install and run Pulse Secure on wine? I have setup the environment variable WINEARCH=win32 as well as selected Windows 7 under winecfg.

When I run wine start JunosPulse.x86.msi the installer "fails prematurely" with the following output to terminal:

> wine start JunosPulse.x86.msi 
fixme:exec:SHELL_execute flags ignored: 0x00000100
> fixme:storage:create_storagefile Storage share mode not implemented.
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:msi:AutomationObject_GetIDsOfNames Unknown member L"CreateObject", clsid {000c109e-0000-0000-c000-000000000046}
fixme:shell:ShellDispatch_QueryInterface not implemented for {fc4801a3-2ba9-11cf-a229-00aa003d7352} (unknown)
fixme:shell:ShellDispatch_QueryInterface not implemented for {a6ef9860-c720-11d0-9337-00a0c90dcaa9} (unknown)
fixme:shell:ShellDispatch_QueryInterface not implemented for {a6ef9860-c720-11d0-9337-00a0c90dcaa9} (unknown)
fixme:vbscript:do_mcall NULL obj
err:msi:ITERATE_Actions Execution halted, action L"writeTncConfigFile.D7CCF602_E814_4416_8EC5_24D6FEA3289C" returned 1603
err:msi:ITERATE_Actions Execution halted, action L"ExecuteAction" returned 1603
err:rpc:I_RpcGetBuffer no binding
err:rpc:I_RpcGetBuffer no binding
fixme:msvcrt:__clean_type_info_names_internal (0x65b260) stub

The backstory is I have tried both: using openconnect as well as tethering to my Pulse Secure authenticated Android device with no success. I have also tried using the Pulse Secure Debian command-line tool, but it seems that SAML authentication is not supported at this time.

  • Just curious if you found a solution to this. I am looking to do the same. I know Junos has a Linux Pulse client now, but I can't get access to download it. – DAB Jan 25 '17 at 19:29
  • No, sorry no progress with this. I am using a script provided by my employer to access VPN. It's a good sign that they are supporting Linux now, though! – jerome Jan 25 '17 at 19:41
  • is PulseSecure some VPN or no? – Thomas Ward Nov 8 '17 at 17:52
  • Pulse Secure's Junipers VPN client. You can basically forget to get it working under wine. – vidarlo Nov 8 '17 at 17:58
  • You might be interested to hear, that there is a native PulseSecure client for linux. (if you can talk your company into supporting it, is another matter) – Frank Nocke Nov 2 '18 at 10:32
0

err:msi:ITERATE_Actions Execution halted, action L"writeTncConfigFile...." returned 1603

Try to re-/install or upgrade your .NET framework (4.5.3+) as per this thread.

You can also try to run MSI installer by:

wine msiexec /i filename.msi
0

You can't install a VPN client in Wine, generally speaking.

VPN software relies on some network adapter in the kernel to pass traffic to and from the network stack. On Linux this is commonly a TUN/TAP device, which passes traffic to a user space program. Windows has a defined interface for network adapters - which is not equal to Linux interface.

So a driver made for Windows will not work in wine. You can not install your Windows VPN client in wine and make it work, no matter what you do. You need to make openconnect work, or run a windows virtual machine. It's possible you could make your Windows machine forward traffic to your Linux machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.