1

I migrated data on my laptop's HDD which contains Windows 8.1 to my SSD and replaced the HDD with the SSD (My laptop has 2 hard drive bays btw). Currently, my Windows 8.1 and Ubuntu 14.04 are on their own SDDs. Before this, I was able to boot straight into the GRUB OS selection screen where I could select to boot into Windows 8.1 or Ubuntu 14.04. But now, every time I start my laptop, I get this screen

enter image description here

Once I type exit into that command line. I get this screen (btw, I have reconfigured to remove the duplicate entry for Ubuntu after I took this screenshot) enter image description here

After selecting ubuntu I am able to see the OS selection screen. enter image description here

Also, when I am in Ubuntu, and restart, it boots directly into Windows without showing the GRUB command line screen. My question is, how can I boot straight to GRUB OS selection screen on startup?

The current boot order entries. enter image description here

Thank you very much

  • check this may help you askubuntu.com/questions/371559/… – Mohamed Slama May 21 '16 at 20:53
  • @MohamedSlama Thank you for your comment. I've tried those solutions. did not help. – Biu May 21 '16 at 23:28
  • Your boot order is messed up. Typing sudo efibootmgr -v in an Ubuntu Terminal will show you the details. Pay attention to the BootOrder line, and review the various options. You may be able to figure out an appropriate boot order and set it with the -o option to efibootmgr. If not, post the output of sudo efibootmgr -v. (Edit your question and post the output, adding four spaces to the start of every line to keep the forum from mangling the formatting.) – Rod Smith May 26 '16 at 17:43
  • @RodSmith Thank you for your input. I've added the screenshot of the output. I removed Windows Boot Manager using EasyUEFI, that's why the line for Boot0001 above is not marked with an asterisk. I still get the grub command line screen however, but it won't boot straight into Windows anymore when I start my laptop after shutting off for a long time, which is great. But I would love for it to boot to the grub OS selection screen directly. – Biu May 27 '16 at 6:24
1

Try this from an Ubuntu Terminal Window:

sudo efibootmgr -o 0

That should fix the problem. Alternatively, you could use EasyUEFI in Windows to move the ubuntu entry to the top of the boot order list.


EDIT:

If it's resetting to boot straight to Windows when you reboot the computer without booting into Windows, then your EFI is badly broken. Check the manufacturer's site for an update (probably called a "BIOS upgrade" or something similar). If that doesn't help, then the best course of action is to return the computer for a refund, assuming you're within the return period. If not, you'll need to employ an ugly hack involving renaming boot loader files. Boot Repair can do this semi-automatically with an option on its Advanced menu, or you can do it manually, as noted here. Either way, if it's a bad EFI, write to the manufacturer to complain! Too many have been delivering junk EFIs for too long!

If this happens only after booting to Windows, then chances are Windows is the culprit. This question covers this variant of the problem.

  • Hi Rod, it still doesn't help, it won't still boot the grub OS selection screen. I even tried to explicitly set the boot order using this command sudo efibootmgr -o 0000,0001,3001,0003,2001,2002, but when I restart my laptop. It still falls back to this order 0001,3001,0000,0003,2001,2002 with the bootnum for ubuntu being pushed to the third. I've also tried setting the boot order and removing the entry for Windows Boot Manger, but when I restart my laptop. Windows Boot Manager still takes precedence over everybody else. I think I am ok right now since it doesn't boot to Windows at least – Biu May 28 '16 at 6:09
  • Please see my edit, above. – Rod Smith May 29 '16 at 14:16
  • You show several hard drive entries. Do not know if UEFI or BIOS. But UEFI hard drive boots /EFI/Boot/bootx64.efi which normally is a copy of Windows efi boot file. You can make that shimx64.efi and using hard drive UEFI boot to boot grub/Ubuntu. Boot-Repair auto copies shim with 'Use the standard EFI file' in advanced options. Or other HP: askubuntu.com/questions/486752/… and: askubuntu.com/questions/597052/… – oldfred May 29 '16 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.