1

I've followed the guide from How to install Ubuntu on Meizu Pro 5 that was originally with Android? All worked fine, but at the end the phone stuck at boot logo "meizu powered by ubuntu".

Was also unsure about the comment "do not flash bootloader and recovery", does it mean i have to remove them from the archive? Or only means i should not use the ubuntu-device-flash? Anyway tried both way, the twrp still works. The ubuntu version i've used is the same as from the original chinese guide (ubuntu-touch/stable/meizu.en) and of course changed the 4 mentioned files. Is there a way to debug what is wrong?

There is nothing new in the /system/var/log/ all of them is from the past.

2

make sure you had extract the four tar.xz files to system partion and flash boot.img, dtb, logo.bin, ldfw correctly

Keep your bootloader unlocked and the recovery is TWRP

You can try rc-proposed with http://system-image.ubuntu.com/ubuntu-touch/rc-proposed/meizu.en/turbo/

1
  • yes, that was it, i've misunderstood the guide and put these 4 files from the kernel-ub and not to the kernel-ub... my mistake, it works now! Thanks! – holdfenytolvaj May 22 '16 at 15:00
0

I had a similar problem. I know that the Flyme recovery mode doesn't really work for some reason. At least it didn't for me. I forget exactly how I got it reinstalled, but it involved using "ubuntu-device-flash" and not manually messing with any of the archives or device images myself. I don't remember if I ended up using the Ubuntu recovery mode or lucked out with the Flyme one. I needed to use fastboot (hold vol down and power while turning on) for flashing the recovery, and I used recovery mode (vol up and power button) to do everything else.

This is about all the info I can offer right now. I don't remember much else about how I reinstalled Ubuntu on my device. Hopefully, this info should help.

I used some version of the following command. Research what each of these options mean and do before you try anything. You won't want developer mode or a password. I may have used developer mode to enable ADB in recovery mode. I'm not sure. Anyway, good luck.

ubuntu-device-flash -v touch --device=turbo --channel=ubuntu-touch/stable/meizu.en --developer-mode --password REDACTED --wipe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.