0

I want to mount a partition to /media/files so that every user can read, write and execute in it. I first tried:

UUID=6c95b3f6-90a5-4092-b30f-7a41210595f4   /media/files    ext4          defaults       0       2

which did not solve it.

I now have tried:

UUID=6c95b3f6-90a5-4092-b30f-7a41210595f4   /media/files    ext4          exec,rw,user       0       2

Without any success either. What should I do? As a sidenote, I want Steam to create a library folder in there.


Update

I now have also chmod-ed the folder /media/files to a+rwx which allows Steam to create a folder /media/files/SteamLibrary. However, it complains that the partition was without execution permissions.

iamuser@desktop:/media$ ls -l
drwxrwxrwx  4 root root 4096 May 21 19:32 files


iamuser@desktop:/media/files$ ls -l
drwx------ 2 root    root    16384 Mai 21 18:58 lost+found
drwxrwxrwx 3 iamuser iamuser  4096 Mai 21 19:39 SteamLibrary

Still using the aforementioned fstab options exec,rw,user

0

Ok... I got this now. What I did with chmod was good, what I did before in fstab was the issue. Now defaults in fstab solves the problem.

So, as a reminder for anybody struggeling:

chmod a+rwx /media/files

will do the trick!

If anybody as something to add about the rigorous permissions, I am happy to hear.

0

The mount option user resets some other options. From man 8 mount:

user   Allow an ordinary user to mount the filesystem.  The name of the
       mounting  user  is  written  to  mtab so that he can unmount the
       filesystem again.   This  option  implies  the  options  noexec,
       nosuid,  and  nodev (unless overridden by subsequent options, as
       in the option line user,exec,dev,suid).
…

users  Allow  every  user  to  mount  and unmount the filesystem.  This
       option implies the options noexec,  nosuid,  and  nodev  (unless
       overridden   by  subsequent  options,  as  in  the  option  line
       users,exec,dev,suid).

So, you need to specify exec after user:

UUID=6c95b3f6-90a5-4092-b30f-7a41210595f4   /media/files    ext4          rw,user,exec       0       2

If you want every user to be able to read, write and execute, that's not a job for ext4 mount options, but for permissions, as you have applied them using chmod.

As a side note, you might have been better off chowning /media/files to your user, instead of giving everybody rwx, or using the user mount option, and set rwx only for you:

sudo chown iamuser:iamuser /media/files
sudo chmod a=rX,u+w /media/files

That should let Steam (running as your user) create files in the disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.