0

I use Ubuntu 16.04 in English and Hebrew, and keep it up to date. I started looking at alternate DE's and installed Mate. In Unity changing between the languages works either by pressing Alt + Shift or by clicking the input method icon and choosing which language I need. In Mate it recognizes that I have Hebrew installed but does not change even the icon when I click Alt + Shift, and when pressing the icon and changing to Hebrew, the icon changes but nothing else does. I can read Hebrew online just fine even in Mate. What is the problem, and how do I fix it?

1

Don't know if MATE is supposed to be different in this respect, but on Unity this terminal command can be used to set input method:

gsettings set org.gnome.desktop.input-sources current 0

The number 0 (zero) means that you set the first available input method. Change it to 1 to set the second etc.

Maybe worth a try on your MATE desktop.

Edit:

Installed MATE out of curiosity, and saw that it is different. Added an additional keyboard layout via System -> Preferences -> Hardware -> Keyboard -> Layouts, and encountered the same problem first. However, after having played around for a while, I could successfully switch keyboard layout. So maybe just relogin or reboot...

2
  • In 'gsettings' there is no org.mate.desktop.input-sources. I tried 'org.mate.interface' and got the reply: 'No such key "current"'. Same for org.mate.applications-browser and org.mate.keyboard-peripherals. I looked at 'gsettings list-schemas' and tried the ones that looked likeliest.
    – Uberhumus
    May 21 '16 at 19:19
  • @Uberhumus: Please see my edited answer. May 22 '16 at 0:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.