I have a fresh install of Kubuntu 10.04.3 on a new motherboard. The driver(s) in the install do not support the Intel 82579V NIC on the motherboard. I've located and downloaded the NIC driver - but of course that requires a compiler to build/install.

There does not seem to be any version of gcc installed by the distro CD. Is that correct? (Seems odd at best to me.)

I've found gcc .deb files at archive.ubuntu.com and https://launchpad.net/~ubuntu-toolchain/+archive/ppa. However the process of downloading (via another computer of course) a bunch of separate/dependent .deb and installing separately is error-prone. Also I am not sure which version of compiler I need.

Can anyone suggest the simplest way to do this?

UPDATE: Per user606723's suggestion, I tried using the CD. I uncommented the CDROM line at the top of sources.list. Then

apt-get install build-essentials

resulted in a 'no package found' message.

apt-get install gcc

offered to install 42MB of packages, but failed to find any of them on the CD

UPDATE_2: I can see the .deb files on the CD via Dolphin file manager. The path appears to be the same as the apt-get error messages.

Also the build-essential (note no trailing s) package is there. However it fails with file not found errors also.

UPDATE_3: Tried rebooting with CDROM out, then

apt-cdrom add
apt-get update
apt-get install build-essential

Result is same file not found errors.

Also tried navigating with Dolphin to the build-essential .deb on the CD and clicking. Brings up Package Installer, which ultimately fails trying to get the first file (probably same underlying error?).

SOLVED: Based on this bug report: https://bugs.launchpad.net/ubuntu/+source/apt/+bug/602945 I added a symbolic link from /media/apt/pool -> /cdrom/pool and now the apt-get install works.

  • 2
    I would be very surprised if gcc is not distributed on the CD. As long as you still the CD in your sources.list, you should be able to install build-essentials from the CD. – user606723 Nov 9 '11 at 17:57
  • @user606723 if you add an answer with your suggestion, I will accept it since that is what got me started on the right track. Thanks. – Steve Fallows Nov 9 '11 at 20:07

I think you should try with newer version of (K)ubuntu, because there is very high chance, that your NIC's driver included in kernel. In fact driver — just kernel module.

By the way, you should verify, that you installed 10.04.3 (not just 10.04), because it includes many updates, including new kernel modules.

  • 1
    Actually I've already installed 11.10 and it does include a working driver for the NIC. However for compatibility with a specific CUDA driver and other systems, I need to get 10.4 working also. And yes it is 10.04.3 I'm working with. – Steve Fallows Nov 9 '11 at 18:17
  • If you need 10.04, you could try to load from 11.10 live cd, chroot and install backported modules for kernel. Very high chances that network will work. Or just install all needed packages and compile module, while in chroot. – tensai_cirno Nov 9 '11 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.