I've created a bootable USB of Ubuntu 16.04 64-bit with Rufus, setting the drive to be a GPT for UEFI. Then I booted my tablet PC and I ran the UEFI BIOS, from which I turned secure boot off. I then restarted and went again on the BIOS to boot from my key, but all I got was a black screen that lasted few seconds and then it brought me back to the BIOS.

I read about a bootia32.efi file and other procedures that can be followed, but I didn't find a good explanation of what I need to get done.

My tablet PC runs an Intel Core Atom Z3735F and has 2 GB of RAM.

If you have the answer please let me know.


1 Answer 1


So far you're doing everything right, you just need to modify the USB so that it will boot on a 32-bit UEFI only system.

While Windows is running or on another machine, insert the USB and find a directory called /EFI/BOOT. This needs to contain a bootia32.efi file (even if there is one there already it might not be one that works - last time I found one but had to replace it)

click here to download a bootia32.efi file that worked for me recently.

Drop this file into the right place (remember all the file and directory names are case sensitive) and your USB should boot, given appropriate UEFI settings (secure boot off, USB first or selected in boot menu)

  • Thank you, it worked! How do I commend your answer? Commented May 21, 2016 at 15:48
  • Awesome! By accepting it, which you did, thank you :-)
    – Zanna
    Commented May 21, 2016 at 17:02
  • 2
    For the search engines, I'd like to add that his FINALLY got me to boot the Xubuntu linux version on my chinese PIPO X3 all in one pos terminal! Thank you! Commented Dec 5, 2019 at 0:49
  • 1
    This file still works with Ubuntu 20.04 when written using Rufus in GPT mode.
    – cjbarth
    Commented Jun 10, 2020 at 20:35
  • 2
    @breversa, I extracted the official Ubuntu iso to a local directory, then copied bootia32.efi to the /EFI/BOOT folder, then ran mkisofs to create a new .iso image and booted successfully from that. Example using RHEL access.redhat.com/discussions/1422213
    – Nick
    Commented Mar 14, 2021 at 20:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .