21

Machine is 64-bit ACPI motherboard with i5 quad-core and 8 Gb of memory running Windows 10-Pro host. Monitor is Acer T232HL touchscreen. Video card is AMD Radeon R7 200.

Installed VirtualBox then created guest virtual machine with 2Gb of allocated memory and 200Gb of fixed virtual disk and 128 Mb of video memory.

Installed Ubuntu Desktop 16.04, then installed Guest Additions. 3D acceleration is checked and confirmed.

Guest machine is still painfully slow, with refresh errors leaving some menus blank.

Any suggestions?

  • Have you tried without that 3D acceleration? And how was it working before installing those additions? – GreggD May 20 '16 at 21:48
  • 1
    Try giving the guest another MB of RAM and two cores instead of one. – rclocher3 May 20 '16 at 22:19
  • 1
    also check to see if the guest additions actually installed properly .. I had it once where I went into Software and Updates and under Additional Drivers it showed the VM drivers but they weren't being used.. I changed them and then rebooted and things got much better. – John Orion May 20 '16 at 23:01
  • Me too :-( . I'm giving the VM 10 out of 12 cores, a GTX 980Ti, 20GB ram allocated and 128mb for video... Guest additions must be working because copy / paste from host, full screen mode, etc are working. – foobarbecue Aug 2 '16 at 15:06
  • The same problem here: 64-bit Windows 10 Home, Asus with Intel Core i7-4770K CPU @ 3.5 GHz, giving the VM 4 out of 8 cores, 8 GB out of 16 GB RAM allocated, NVIDIA GeForce GTX 660. Reinstalled Guest Additions. The problem arose after I upgraded from Ubuntu 15.10 to Ubuntu 16.04 today. – Shy Robbiani Aug 18 '16 at 15:45
15

Some general troubleshooting...

  • Make sure Unity can use 3D acceleration - it makes a big difference. Run /usr/lib/nux/unity_support_test -p from the terminal and note whether the last line shows Unity 3D supported: yes. If not, enable it in the VM options.

  • Check you have given it enough video memory. The default settings in VirtualBox for guests are pretty low. Give it 64MB at least, and 128MB if you can.

  • Check screen resolution. No matter what hardware I try, it just can't seem to power my 4K screen at its native resolution (3840 x 2160). Significantly better experience at 1920 x 1080, scaled.

  • Check CPU virtualisation settings. If you have, say, a 4-core CPU don't assign all 4 cores to the VM. If you do that, the VM guest will fight the host for resources and the result is that it will actually run slower. Stick to one or two cores. (There's not much difference between 1 and 2 in my experience, but yours may differ).

  • Do the same for RAM as for CPU. Don't assign more RAM than you need - ensure the host has enough left for itself. 4GB for Ubuntu desktop seems fine for practically everything I throw at it.

  • I've read that people get better speeds on a mechanical hard disk by using a fixed allocation virtual HDD rather than dynamic. In my experience there's no noticeable difference, but perhaps worth mentioning anyway.

  • Significantly better experience at 1920 x 1080, scaled. - Fixed my issue. Many thanks! – jbrya029 Feb 1 '18 at 18:18
  • 1
    Unity does not seem to be installed in the 16.04 Virtualbox by default. So /usr/lib/nux/unity_support_test -p will give a No such file error. You can install it normally: sudo apt install unity. It's a 500 MB package though. – Juha Untinen Feb 15 '18 at 9:10
2

I want to share what I figured out, and trust me it took me very long:

Ubuntu Unity likes a real graphics card, not virtual stuff from vmshare or virtualbox

It just doesn't work well in virtual box.

You can try all the stuff the other guy posted and it will be better, but not like you want it to be. Basically: don't waste your time.

Alternatively:

Use another distribution that does not use Unity as UI.

I've successfully used Lubuntu 14.04

Not 16.04, because I did it a couple years back. And I think Lubuntu changed their UI, so be warned.

Another option is to switch to Gnome, but that switch has to be done completely, without exception... ( Ubuntu will go back to gnome in 2018 anyway )

I remember trying something like that back when I had my problems, and it did not work well neither...

There SEEMS to be an option to uninstall it via this.

A friend of me is doing that just that right now. I will let you guys know about it.

Better:

Use an image that comes with a different UI engine. Gnome, KDE, Lubuntu are some examples that should work. Lubuntu works for sure, at least in 14.04.

EDIT:

So my friend tried out and said Lubuntu 16.04 does feel a lot faster and more native than his Ubuntu install. But instead of reinstalling everything on Lubuntu, he tried out switching to gnome and followed this guide (mentioned earlier).

He said that after switching to gnome and removing Unity, it feels a lot more native.

  • There is a reason Ubuntu exists. You are pointing out some very valid things here, of course he can also go back to Arch Linux or LFS, they don't take any memory at all it seems at the beginning. – Vijay Kumar Kanta Jul 12 at 17:03
2

One for people landing from Google (rather than chronic sufferers):

I observed very poor performance having "slept" the Windows 10 host with the VM running. A VM reboot resolved the issue. Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.