I saw in my Ubuntu 14.04 installation that there is a process called wineserver.

Is that a default process/program when you install Ubuntu? I have another machine running the same OS (14.04) and don't have this process running.

PS.: I don't have wine (run win apps) installed in both machines.

  • You answered your own question, "I have another machine running the same O.S 14.04 and dont have this process running." so as you can see wine / wineserver is not installed or running by default. – Panther May 20 '16 at 20:05
  • Yes. But is there possible that when install other program it install wineserver? why is that process there? for what? maybe some one install it manually? how do I know how and when it was installed? – rafaelphp May 20 '16 at 20:10
  • Did you install Wine on the system? – muru May 20 '16 at 21:28
  • No, never. only use it to access others hosts from this machine ip(allowed on remote servers). what this service is doing? any suggestions? – rafaelphp May 20 '16 at 21:52

wineserver is a component of wine. It shouldn't be present in a default clean Ubuntu installation. Someone either manually installed it or it was installed as a dependency of another package.

Please try the following:

  1. Where is wineserver?

    Use which to find out:

    $ which wineserver 

    winserver's full path is /usr/bin/wineserver.

  2. What package "owns" that file?

    Use dpkg -S:

    $ dpkg -S /usr/bin/wineserver
    winehq-devel: /usr/bin/wineserver

    /usr/bin/wineserver is there because it is part of package winehq-devel.

  3. Why is that package installed? (You'll need aptitude for this, or you can also use apt-cache --installed rdepends <package>)

    Run aptitude why:

    $ aptitude why winehq-devel
    i   playonlinux  Depends  wine | wine-development
    i   winehq-devel Provides wine                   

    winehq-devel was manually installed (the line starts with i A for automatically installed packages). It's also a dependency of package playonlinux, so if I uninstall winehq-devel I have to uninstall playonlinux, too.

  4. If you don't need it, remove it.

    sudo apt-get purge winehq-devel
  5. When was it installed?

    dpkg maintains a log in the files /var/log/dpkg.log*

    $ grep "install winehq-devel" /var/log/dpkg.log*
    /var/log/dpkg.log.1:2016-04-04 14:01:31 install winehq-devel:amd64 <none> 1.9.7~ubuntu16.04.1

    Of course, replace winehq-devel with the actual name of the wine package installed in your system. As you can see, winehq-devel was installed on 2016-04-04 14:01:31.

    There's also the apt logs located at /var/log/apt/history.log*. I found this in file /var/log/apt/history.log.1.gz:

    Start-Date: 2016-04-04  14:01:00
    Requested-By: carvalho (1000)
    Install: ..., winehq-devel:amd64 (1.9.7~ubuntu16.04.1), ...

    No surprise, I intentionally installed winehq-devel.

Good luck!

  • Hi, thanks for help. 1.) when I run: '#sudo which wineserver' , it return nothing. 1.1) '#ps -A | grep wine' , show pid number and wineserver 1.2) '#ls - l /usr/bin/ | grep wine' , try find wineserver path like you said and return nothing 1.3) so I run your command but different because I dont have any wineserver on /usr/bin so I run '# dpkg -S wineserver' , and it return my TEAMVIEWER wineserver path '# /opt/teamviewer/tv_bin/wine/wineserver' I think I solve my problem, teamviewer use wineserver or whatever, right? – rafaelphp May 24 '16 at 3:29
  • 1
    @rafaelphp I just found this and this. Yes, Teamviewer runs on Wine. There's nothing wrong with your system. – Eric Carvalho May 24 '16 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.