13

I've downloaded a theme from GNOME-Look and followed the instructions in the readme file. This is not the first time I've tried installing a custom splash screen. It tells me to do something. I followed this tutorial, and at the end, he tells me to run sudo update-initramfs -u, as well as here in this current theme's readme file. Problem tho, is that no matter what I do, I always get this error:

W: plymouth module "(/usr/lib/i386-linux-gnu/plymouth//.so)" missing, skipping that theme.

Admittedly, I'm not new to Ubuntu, but I'm absolutely no expert. I have no idea what to do now.

EDIT: I know that plymouth is already the newest version (0.9.2-3ubuntu13.1). when I run sudo apt-get install plymouth Also, I'm running Ubuntu on VirtualBox, so it isn't using proprietary drivers. Resolution and everything is fine. I don't even know if the W: plymouth module "(/usr/lib/i386-linux-gnu/plymouth//.so)" missing, skipping that theme is the cause of the problem, but I'm guessing so. I follow all the steps, it's that at initramfs -u which I get this error and then it returns to the old splash screen.

| improve this question | | | | |
  • 4
    Possible duplicate of What alternatives are available to replace the purple boot splash screen? Follow the instructions here, leave a comment on this question if it does not work. – Mark Kirby May 20 '16 at 20:39
  • @MarkKirby thanks for telling me that. I kept googling "W: plymouth module "(/usr/lib/i386-linux-gnu/plymouth//.so)" missing, skipping that theme." and didn't get any relevant results so I just thought of posting here. I didn't think it could have been posted a totally different way. I'll check it, cheers! – Ram the Cowy May 22 '16 at 10:58
  • @MarkKirby well I tried what you linked to, with no success. Running sudo update-initramfs -u returns W: plymouth module "(/usr/lib/i386-linux-gnu/plymouth//.so)" missing, skipping that theme. again. I checked through the entire list of issues that people had which was linked to in the solution post, but none of those answered my question. No go. sudo reboot, still get old splash screen. – Ram the Cowy May 22 '16 at 11:13
19

I also encountered this problem, here's how I fixed it.

The basis of the problem

Put simply, the file layout in Ubuntu 16 changes the location of plymouth themes from /lib/plymouth/themes to /usr/share/plymouth/themes and so all of the theme install scripts that assumed the previous layout now install to the wrong location. Thus, when update-initramfs runs, the source data is not where it's supposed to be which causes this error.

plymouth module "(/usr/lib/i386-linux-gnu/plymouth//.so)" missing, skipping that theme

and because of that, the theme is not installed. The fallback is the default ubuntu logo theme.

Fixing things

I found it convenient to simply perform things manually, and since you're familiar with Ubuntu, I'll concentrate on describing the approach rather than making it cut-and-paste like.

Partially initialize-correct with apt-get

Run the following command which will not only install a number of new themes into the correct location but also will fix the now incorrect update-alternatives scheme.

apt-get install plymouth-themes

after this runs there will be a new directory structure anchored in /usr/share/plymouth/themes which will have an identical layout to the previous path.

Move old themes

Consider if each theme is worth migrating, there might be duplicates in which case use the already installed ones.

ls -ltrd /lib/plymouth/themes
ls -ltrd /usr/share/plymouth/themes

migrating to the new location is simple; just move the directory as each theme is contained in a directory named after the theme

cd /lib/plymouth/themes
mv <theThemeDirectory> /usr/share/plymouth/themes

Fix old themes

The old themes are self-referential in that the .plymouth theme file contains a reference to the directory that the theme is installed. Change these references to the correct ones (e.g. vi /usr/share/plymouth/themes/orb/orb.plymouth and then replace /lib/plymouth with /usr/share/plymouth).

Update list with update-alternatives

Extending the orb example, use update-alternatives to make the theme list selectable.

update-alternatives --install /usr/share/plymouth/themes/default.plymouth default.plymouth /usr/share/plymouth/themes/orb/orb.plymouth 100

This has the added benefit of leveraging the script update-plymouth that is included with most themes from gnome-look. I'll include the text

#!/bin/bash

echo "Choose the number of the theme you want to use, then [ENTER]"
echo
sudo update-alternatives --config default.plymouth
sudo update-initramfs -u
echo
read -p "Do you want to test the theme? (Y/N) "
if [ "$REPLY" != "n" -a "$REPLY" != "N" ] ; then
 echo
 echo "Running 10-second test..."
 sudo plymouthd ; sudo plymouth --show-splash ; for ((I=0; I<10; I++)); do sleep 1 ; sudo plymouth --update=test$I ; done ; sudo plymouth --quit
fi
exit

Running update-plymouth will allow you to select the theme you want, automatically build the new initramfs and let you preview it.

Bonus: use art from deviantart

Armed with this knowledge, we don't blindly have to run an installer, but rather with the understanding that all it takes to install a new theme is

  1. copy a theme directory to /usr/share/plymouth/themes
  2. run update-alternatives as described above
  3. run update-plymouth

That gives us access to larger selection of themes of which I think this sonic theme is the best.

| improve this answer | | | | |
  • damn, this is insane! Thanks a ton for the quick reply, and man, do I love these forums. You're awesome. I will try what you suggested and get back to you shortly. I was aware that the Plymouth themes directory was different, but wasn't too sure what to do about it. Cheers! – Ram the Cowy May 23 '16 at 18:02
  • So let me give you a heads up where this is. I understand the change in Plymouth theme location. I left the folder in the old /lib/plymouth/ubuntu-sunrise the way it is. Now, fresh from the unpacked file, I moved it to /usr/share/plymouth/themes. I already had the Plymouth directory under /usr, so running apt-get install plymouth-themes gave me the message that was up-to-date. I moved that one theme I needed. I went into the ubuntu-sunrise.plymouth file, edited both lines. Did the same even back in /lib/plymouth/ubuntu-sunrise/ubuntu-sunrise.plymouth. Did the update-alternatives. – Ram the Cowy May 23 '16 at 19:32
  • And after that, to make sure, I ran update-alternatives --config default.plymouth and made sure it was listed. (Either way, the theme didn't come with a update-plymouth script so I had to run stuff manually.) Selected the theme. sudo update-initramfs -u, no error messages popped up (WOO!). Then I copied the line of code you gave from the update-plymouth that tests the splash screen. Sure enough, it worked. Here was what baffled me though. Immediately after, I ran sudo reboot and.... it went back to the old splash screen. ARG! – Ram the Cowy May 23 '16 at 19:37
  • Hmm, this feels like a different problem. If the test is working, then the theme is correct and in the right spot and the initrd should have it. These animations take over in the 2nd half of the boot process and need grub to have GRUB_GFXMODE=*some relevant value* GRUB_GFXPAYLOAD_LINUX=keep. The initial spalsh screen also seems like a direct grub thing rather than plymouth. – waTeim May 23 '16 at 19:48
  • let me retry the entire thing all over again. – Ram the Cowy May 24 '16 at 20:29
4

If you have followed @wateim answer and still getting the error W: plymouth module "(/usr/lib/i386-linux-gnu/plymouth//.so)" missing, skipping that theme. then most probably the theme is old. New theme convention is slightly different

  • Theme directory name should match with Plymouth file name. Ex: If Directory name is aurora-penguinis then plymouth file name should be aurora-penguinis.plymouth
  • Change ImageDir and ScriptFile in plymouth file to new base location (/usr/share/plymouth/themes/)

Do these changes. It should work :) If you want to start all over again, check out my blog post. Its almost same as @wateim answer but with slight modifications (works for me in Ubuntu 16.04+)

| improve this answer | | | | |
  • after moving themes to /usr/ path renaming the theme folder to match the .plymouth name did the trick for me – northern-bradley Sep 6 '18 at 13:00
  • The thing bout the dir name matching the Plymouth file name was what was causing the trouble for me. Thank you! – Peterson Silva Oct 22 '19 at 9:14
2

I also stumbled around with W: plymouth module "(/usr/lib/i386-linux-gnu/plymouth//.so)" missing, skipping that theme.

I copied over the current theme, in my case ubuntu-gnome-logo customized and installed it.

Make sure the .grub, .plymouth and .script files located in your theme have the same name as the theme folder. After proper file renaming the error message was gone and the custom splash screen appeared as expected.

| improve this answer | | | | |
2

This error happens because the location of the Plymouth files has changed. In older versions of Ubuntu they were located in /lib/plymouth but now they are located in /usr/share/plymouth. What you have to do is reinstall like this:

sudo apt-get install --reinstall  plymouth-themes

Then choose a theme that is in the path /usr/share/plymouth/themes after running:

sudo update-alternatives --config default.plymouth

Then to save the theme, so that it starts with this at the beginning of the system run:

sudo update-initramfs -u

To test you can execute this command:

sudo plymouthd --debug  ; sudo plymouth --show-splash ; for ((I=0;I<10;I++)); do sleep 1 ; sudo plymouth --update=event$I ; done ; sudo plymouth --quit

If you want the old themes then you have to move them from your old location and edit the file with *.plymouth extension with the new path that is /usr/share/plymouth/themes/your_you and then install them like this:

sudo update-alternatives --install /usr/share/plymouth/themes/default.plymouth default.plymouth /usr/share/plymouth/themes/BootSplash/BootSplash.plymouth 100

Then select it by running:

sudo update-alternatives --config default.plymouth

To start the system with this:

sudo update-initramfs -u
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.