12

On my dual-monitor setup some windows get off screen after the sleep (suspend) mode. I have to manually Alt+Space to move them back. How can this be accomplished automatically after the sleep?

  • Have you tried checking 'additional drivers' for the latest video drivers? – nullsteph Sep 5 '16 at 14:23
0

Try disable the external monitor before going to sleep (if you think this complex procedure is worth it) in this way... https://unix.stackexchange.com/questions/149959/how-to-run-systemd-user-service-to-trigger-on-sleep-aka-suspend-hibernate and use the xrandr command to disable (before going to sleep) and re-enable it (after returning from sleep)

0

Try pressing Ctrl+Alt+F1 (or F2...F6) to go into a text-mode vconsole, then Ctrl+Alt+F7 to switch back to graphics mode.

This forces the window system to re-draw everything, which often clears up graphical glitches such as what you describe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.