1

Suddenly from today my Geany editor doesn't run at all neither from shortcut nor from terminal.

My Ubuntu version is 14.04 Trusty Tahr.

Geany version is 1.26.

I also tried re-installing the latest version 1.27 but still not working.

If I try to start geany from command-line then it gives error:

Segmentation fault (core dumped)

What possibly could be the issue ? Previously it was working fine.

0

This is a bug and some kind off topic here. However, there are 2 things to do:

1: Run Geany with gdb and send a backtrace to Geany devs. Do it like this

  • Install gdb from repository
  • Run gdb Geany followed by pressing r for running
  • When Geany is crashing, type bt and send the out to Geany devs (e.g. via GitHub) or report a bug against Ubuntu
    (Really, it's a bug for sure)

2: Most likely one of the plugins is buggy or another setting you have done is faulty. Move ~/.config/geany/geany.conf out of the way -- e.g. renaming is ok -- and start Geany. It should start with defaults. Don't delete old geany.conf as it might be should included to the bug report from step 1 later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.