2

On both Ubuntu and Ubuntu Gnome, I have working wifi in the installer, but not after. There is no wireless device in the network settings, and I've tried the following with no luck:

WIfi Issues with Macbook Pro Retina Early 2015 (12,2) on Ubuntu 15.04

wifi problem on MacBook pro early 2015 running Ubuntu LTS 16.04

Here are some details:

$ lshw -C Network
   *-network               
   description: Wireless interface
   product: BCM43602 802.11ac Wireless LAN SoC
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 01
   serial: f4:5c:89:8e:0f:79
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=brcmfmac driverversion=7.35.177.61 firmware=01-ea662a8c latency=0 multicast=yes wireless=IEEE 802.11abgn
   resources: irq:63 memory:c1400000-c1407fff memory:c1000000-c13fffff

and

$ lspci -nn | grep 0280
03:00.0 Network controller [0280]: Broadcom Corporation BCM43602 802.11ac Wireless LAN SoC [14e4:43ba] (rev 01)

Edit: It seems Ubuntu is incorrectly treating the adapter as wired on every reboot. Closing and re-opening the lid seems to temporarily fix it for whatever reason.

5

After a "fresh" installation of Ubuntu 16.04, the driver for my wifi hardware Broadcom Corporation bcm4322 was not detecting any wifi networks in my MacBook Pro (Core 2-Duo from 2010).

Fortunately, while being connected through wired Ethernet I found a work around:

  • go to System Settings | Software & Updates, then pick the Additional Drivers tab.
  • There was a section "Broadcom Corporation: BCM4322 802.11 a/b/g/n wireless LAN Controller" with an UNSELECTED radio button labeled "Using Broadcom 802.11 wireless driver source from bcmwl-kernel-source (proprietary)" and also a SELECTED radio button labeled "Do not use the device". The only thing I did is clicked the former UNSELECTED radio button and within a few minutes it got the wifi connections worked perfectly

protected by Community Aug 10 '18 at 14:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.