After I did a fresh install of 11.10 but keeping my home folder which was used for 11.04, my laptop speakers didnt work anymore. Sound from analog headset still works, but would like to use my speakers also.

My laptop is the HP625 and the soundcard: Card: HDA ATI SB(Radeon HD 4200)
Chip: IDT 92HD88B1

I have tried the following things:

  • Followed this answer and changed some kernel settings: Fast video playback with no sound
  • Unmute the speakers
  • ran the troubleshooting guide of ubuntu, which caused more trouble than it solved, all my sound stopped working and had to reinstall the kernel, so it would recognize my soundcard again

As a reference this is the aslascript, which may provide a linux/ubuntu guru more info than me: alsa information script


You can try following steps:

  1. First,open up a terminal window (Applications->Accessories->Terminal) and run this command:

    sudo head -1 /proc/asound/card0/codec#0

    it outputs your audio card type.

  2. Edit the configuration file by this command:

    sudo gedit /etc/modprobe.d/alsa-base.conf

    find out this section:

    > # Keep snd-pcsp from being loaded as first soundcard 
    > options snd-pcsp index=-2

    change it into:

    > # Keep snd-pcsp from being loaded as first soundcard
    > #options snd-pcsp index=-2
    > options snd-hda-intel model=laptop-eapd

Reboot,and the speaker should be working now

  • Worked! Thanks a lot, i edited your answer as it contained some formatting bugs, which may cause other readers to do the wrong thing, which nearly happened to me. Btw could you tell me why we run the first command? I didn't use it when editing the config file, so I do not see the use of it. It's good to know but not related to the answer? – Sam S Nov 10 '11 at 12:49
  • Don't know why but my laptop speakers stopped working again, after switching from headset to speakers. I got it working for like 30 mins. Any idea? I am using Analog Speakers as output, as that worked just now, but does not work now anymore. – Sam S Nov 10 '11 at 13:16
  • @SamS have a view on this help.ubuntu.com/community/SoundTroubleshootingProcedure – twister_void Nov 10 '11 at 13:25
  • I fixed it by buying external speakers haha, they were 5 euros and the quality of the sound is much better also. So for anybody with the same problem as me I suggest buying some external speakers ;) The sound is so much better! – Sam S Nov 12 '11 at 12:47
  • :D NIce Shoot @SamS – twister_void Nov 12 '11 at 16:06

Select as output device the ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40) card.

Click on the sound icon near your username on the top right corner, select Sound Settings, go to the Output tab, bellow there will be a list with the output devices available, select the output device you want and select the connecter that you want to use to output your sound.

Also on your Hardware tab you can set the profile for each sound device you have, there you can set your devices "abilities" so check if none is set to off.

Normally the card you have currently selected will be responsible for the HDMI sound coming out on your HDMI port.

  • That device is not available. The only 2 devices available are: Internal Audio Analog stereo and RS880 Audio Device [Radeon HD 4200] Digital Sterio [HDMI]. But I have tried all options available in the soundmixer but none of them worked – Sam S Nov 10 '11 at 14:09
  • It is solved right? – Bruno Pereira Nov 10 '11 at 14:11
  • Well I thought it was, but it only was solved for like 20 mins, no idea what happened after that because I didnt change anything.. – Sam S Nov 11 '11 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.