35

This question already has an answer here:

I tried to install crossover and after downloading the .deb from their website, I followed the steps as indicated when opening it with Ubuntu Software Centre:

On 64-bit flavors of Debian and some Ubuntu variants, first open a terminal and run sudo dpkg --add-architecture i386 ; sudo apt-get update

Since I have Ubuntu 16.04 LTS 64 bit I perform the command.

But when copying and pasting that command into my terminal, it stopped at Fetched 535kb in 7sec and stalled there for about 20 minutes. I ended up closing it and tried to run both commands separately but after doing the sudo apt-get update command it also stalls again after "Fetched XXKb in XXsec."

I restarted my computer and decided to run the software updater and it stays stuck at roughly 75% for hours.

marked as duplicate by Braiam, jokerdino May 21 '16 at 10:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Try setting your DNS servers to 8.8.8.8 and 8.8.4.4. That fixed it for me when I had this problem. – Android Dev May 19 '16 at 23:16
  • 2
    I am currently having similar issues and it seems to be related to this thread on the Ubuntu Forums where appstreamcli refresh is pegged at 100% in the processes tab and will completely max one of my cores when the update command is running which leads me to believe that this may be a bug in appstreamcli. – Michael Lindman May 20 '16 at 0:01
  • I looked at my CPU resources and core 7 is at 100% where as the other 7 are normal at like 1-2%. Thanks for the help! – Steve May 20 '16 at 0:21
  • 1
    I can confirm the issue here, with appstreamcli taking 100% cpu. Killing it just makes apt-get fail immediately. – isanae May 20 '16 at 0:55
  • I had a problem similar to the one in the title, but unrelated to appstreamcli. It was solved after I rebooted the computer. – Erel Segal-Halevi Feb 7 at 14:59
51

This is a known bug and has been fixed. From a comment in the bug tracker, installing the following packages manually solves the problem, at least for me (the URLs are for amd64, adjust URLs for other architectures):

cd /tmp && mkdir asfix
cd asfix
wget https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb
wget https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb
sudo dpkg -i *.deb
cd ..
rm -r asfix
  • I am on Ubuntu 16.04 with an ARM processor and this didn't work for me. I replaced amd64 with arm64, everything ok. I was able to fetch the files but then when I run sudo apt-get update I am always stuck – kalmanIsAGameChanger Apr 19 '18 at 12:42
7

The bug has been fixed. The packages can be downloaded and installed by opening a terminal (press Ctrl+Alt+T) and running the following three commands:

wget http://launchpadlibrarian.net/259142419/libappstream3_0.9.4-1ubuntu1_amd64.deb http://launchpadlibrarian.net/259142413/gir1.2-appstream_0.9.4-1ubuntu1_amd64.deb http://launchpadlibrarian.net/259142412/appstream-index_0.9.4-1ubuntu1_all.deb http://launchpadlibrarian.net/259142418/appstream_0.9.4-1ubuntu1_amd64.deb
sudo dpkg -i libappstream3_0.9.4-1ubuntu1_amd64.deb gir1.2-appstream_0.9.4-1ubuntu1_amd64.deb appstream-index_0.9.4-1ubuntu1_all.deb appstream_0.9.4-1ubuntu1_amd64.deb
sudo apt update
1

I ran into a similar issue (stuck apt update on 16.04, 2x apistreamcli at 100%), however that was not related to any particular installation.

For me it was enough to kill -sigterm the stuck apistreamcli-processes. After that apt update && apt upgrade worked again without issues.

Not the answer you're looking for? Browse other questions tagged or ask your own question.