0

I can't seem to find the answer to my configuration problem. I have 2 graphic cards, one on the motherboard (aspeed) and one on PCI-E (Nvidia).

lspci | grep VGA
04:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
0a:00.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 30)

both are recognized as providers by xrand:

xrandr --listproviders          
Providers: number : 2
Provider 0: id: 0x1e3 cap: 0x1, Source Output crtcs: 4 outputs: 4 associated providers: 0 name:NVIDIA-0
Provider 1: id: 0x41 cap: 0x0 crtcs: 1 outputs: 1 associated providers: 0 name:modesetting

BUT, the onboard GPU does not display anything past the boot process, I don't have access to it in the "Display" tool to configure screens, nor in the Nvidia X Server Settings (see screenshots) Moreover, if I switch tty (say with Ctrl+Alt+F3 for example), then the onboard GPU is the one that gets activated (consistent with the fact that the OS boots on it).

How to I get my desktop to extend to the second GPU (and 4th screen) ? How to I get Ubuntu to add that GPU to my current X server ?

Thanks!

PS: I don't have a xorg.conf, I only have xorg.conf.05192016 xorg.conf.nvidia-xconfig-original and xorg.conf.backup, and whenever I make a xorg.conf, it disappears at next reboot.

Display configuration Nvidia GPU configuration Nvidia

  • No one to help ? :sadness: – Xqua May 24 '16 at 23:23
1

Here is why:

Aspeed is your onboard GPU, whose driver is not provided by Nvidia. Thus, it not showing up in your Nvidia X server settings should be expected.

  • Oh I see ! Any idea how I could get it to show up there ? ? – Xqua Jan 26 '17 at 17:54
  • Umm I am not so sure - maybe you can't since it is technically managed by Intel? – Ryan Li Jul 11 '17 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.