1

I was trying to install VirtualBox in my machine. I found that I need the kernel sources to do so. To see which kernel sources I needed I checked uname -r which gave:

3.2.0-59-generic-pae

The first attempt

% sudo apt-get install linux-headers-3.2.0-59-generic
E: Unable to locate package linux-headers-3.2.0-59-generic 
E: Couldn't find any package by regex 'linux-headers-3.2.0-59-generic'

basically said that it could not find the sources, right? The odd thing is that in Ubuntu site I can find them.

I tried to install it (after downloading it) via dolphin file manager so using QApt but dependencies were not met and it failed.

Also I tried to install them via Muon package manager but it's not appearing.

My question is why I cannot find it in the repositories. There seem to exist only linux-headers-3.4 sources but not for 3.2. Why?

My system uses Kubuntu 14.04 32bit. So how do I solve this problem?

  • "I found that I need the kernel sources to do so" no you don't, otherwise this sounds like an XY problem. How were you trying to install Virtualbox? – xangua May 19 '16 at 18:35
3

Ubuntu 14.04 came with the 3.13 kernel, not 3.2. It seems you are still running on an old kernel which was left around from an upgrade from 12.04. You should reboot into the newer kernel, and then purge all old kernels from your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.