51

I recently added the the Macbuntu theme in my Ubuntu 16.04 from the site [Noobslab][1], In am learning GTK+ for Python too (PyGTK), earlier when I ran the test programs I made run quietly without showing any error in stderr stream but after I installed the theme, I am getting a warning

(radio_button.py:6696): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
(radio_button.py:6696): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

For example when I ran the script of radio_button.py.

I want to fix this error, without uninstalling the theme.

2
  • 1
    Is the Macbuntu theme compatible with the gtk3 version in 16.04 (3.18)? Does it need an engine? Does your system have the appropriate engine?
    – DK Bose
    May 20, 2016 at 1:21
  • This SE page could be related/cross-site-duplicated
    – Cadoiz
    Sep 21, 2022 at 9:13

3 Answers 3

79

I had the same issue

sudo apt install gnome-themes-standard

Fixed the issue.

2
  • 1
    Thanks. I wasn't getting any explicit error, but some Gnome programs were looking like old X apps on my fresh Ubuntu install when using the default "Adwaita" theme, and this fixed it.
    – Cerin
    Mar 26, 2018 at 18:02
  • 8
    Doesn't fix it for me.
    – Carlo Wood
    Apr 23, 2020 at 15:11
5

In order to remove this warning (you can live with it, it is not causing any problem) the solution above did not worked for me. I had to, on top of installing gnome-themes-standard, do the following: $ sudo apt-get install gnome-themes-extra gnome-themes-extra:i386

In my case was the 32 bit architecture version that did the trick.

2
  • 7
    And also this isn't fixing it.
    – Carlo Wood
    Apr 23, 2020 at 15:11
  • 6
    E: Unable to locate package gnome-themes-extra:i386
    – mae
    Jun 17, 2021 at 15:52
0

Ran into the same error recently also. The fix was painless.

> gimp

> (gimp:925393): Gtk-WARNING **: 01:45:23.097: Unable to locate theme engine in module_path: "adwaita",

First, search for packages that might contain the missing item. In this instance, I ran a search for 'theme' and 'adwaita' - the two clues provided in the error.

> sudo apt search themes adwaita

Sorting... Done
Full Text Search... Done

gnome-themes-extra/mantic,now 3.28-2ubuntu1 amd64 [installed]
  Adwaita GTK 2 theme — engine

gnome-themes-extra-data/mantic,mantic,now 3.28-2ubuntu1 all [installed]
  Adwaita GTK 2 theme and Adwaita-dark GTK 3 theme — common files

tcl-awthemes/mantic,mantic 10.4.0-1 all
  Dark and light themes for Tk

>

Second, I installed the packages listed that 'fit the bill'...

> sudo apt-get gnome-themes-extra gnome-themes-extra-data
>

Reopened the 'offended' program (in this case gimp) and no more complaints.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .