13

I am having a problem that when I try to use make command.

I cannot run the Make command.

Message: bash: make: command not found

When I used

sudo apt-get remove make
sudo apt-get install make

or with

sudo apt-get install --reinstall make

it shows

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package make is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'make' has no installation candidate
5
  • On using sudo apt-get install --reinstall build-essential it shows :=Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package build-essential May 19, 2016 at 10:09
  • What version of Ubuntu are you using? May 19, 2016 at 12:22
  • Ubuntu 16.04 iso file was used May 19, 2016 at 16:57
  • It sounds like the repository may be missing from your software sources - have a look at the information on how to Add additional software repositories and make sure that at least xenial main is selected. May 19, 2016 at 18:48
  • Have you run update command before installing? May 20, 2016 at 8:23

2 Answers 2

20

Do an reinstalation of the build-essential package:

sudo apt-get install --reinstall build-essential

This should fix it.

-1

The program make isn't really called that on the package, the package you are looking for is automake

2
  • 1
    How did you arrive at that conclusion? dpkg -S $(which make) says it's in the package make on my system May 19, 2016 at 12:24
  • simply by installing automake by accident and then having a package that needed to be compiled with make and it worked, so i went back, removed automake downloaded a different package, and it said the same error as op, reinstalled automake and it works again
    – patrick
    May 19, 2016 at 12:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.