I have ssh connection with a remote machine (ssh username@server). But now I want to open a certain folder path/to/folder in a GUI environment. The following I've tried while being in username@server:/path/to/folder:


nautilus .


The program 'nautilus' is currently not installed.
To run 'nautilus' please ask your administrator to install the package 'nautilus'

So nautilus is not installed on the remote machine, but it is on my local machine.

I've tried xdg-open aswell. It does work, but that is not really what I want. I want the same interface while browsing my local machine (so basically nautilus).

Is there a way to do this in Ubuntu 14.04?

Thanks in advance, if there is anything unclear, please ask!

PS. I do not have the rights to install anything on the remote machine.

  • 2
    Basically you use 'Connect to Server' in your local nautilus to connect to the remote system using sftp/scp (separate from your ssh terminal session) – steeldriver May 19 '16 at 12:33
  • @steeldriver Thanks for the suggestion. I found a similar solution but with the terminal. I've included your suggestion to the answer as well – SjonTeflon May 20 '16 at 13:13

You can use the sshfs protocol. This allows you to mount any remote file system that you have permissions to over the SSH protocol easily.

sudo apt-get install sshfs
mkdir ~/Remote
sshfs user@remotehost:/path/to/remote/folder ~/Remote

It will ask you for your SSH credentials if you aren't set-up with public-key authentication. Then you can open it up in your local Nautilus or any other file manager, as well as work with the files in the terminal. Also note that the mkdir line is only needed the first time you mount. After the first time mounting, all you need to do is:

sshfs user@remotehost:/path/to/remote/folder ~/Remote

When you are done:

sudo umount /home/<USER>/Remote

While it is mounted, you will have the same permissions as whichever user you connected through SSH as. So, if you mount a folder where your SSH user only has read access, you will only have read access.


Two methods worked for me:

  1. Solution of steeldriver (see the comment under the question):
    'Connect to Server' in local nautilus to connect to the remote system
  2. Similar solution but in the terminal:
    Open the terminal (Alt+Ctrl+T) locally and run: nautilus sftp://username@server:/path/to/folder or even better nohup nautilus sftp://username@server:/path/to/folder & to keep it running even when the terminal is closed.
  • Remember to select this as the answer tomorrow. – Oxwivi May 20 '16 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.