2

So the default behavior of the Ubuntu login screen was that it would match match my Desktop wallpaper. So for example, if I was on the login screen and I clicked between my username and the Guest user, the wallpaper would change to either the same wallpaper that was on my Desktop, or the "default" wallpaper for guest.

In an attempt to disable the Guest user, I ran this command:

echo allow-guest=false | sudo tee -a /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf

However, now that I've done this, the Ubuntu login screen no longer matches the wallpaper that's on my Desktop, it's just stuck on the default one.

I tried going back to this file and removing the "allow-guest=false" line altogether, but this hasn't changed anything. The Guest account is re-enabled, but the wallpaper on the login screen still isn't matching my Desktop wallpaper.

I've found many posts on how to make the Login and Desktop wallpapers different, but I want it to go back to the default behavior where the Login wallpaper matches my Desktop wallpaper. I can't seem to find any posts on this. Is there a conf file somewhere that may have gotten messed up? I'm tempted to just reinstall Ubuntu but surely there's a much simpler fix...

UPDATE:

I just wiped and reinstalled Ubuntu, and remounted /home (/home is kept on a separate partition), and now a slightly different version of the issue is happening. If I use one of the built-in Ubuntu wallpapers, everything works as it's supposed to. However, if I use a wallpaper from ~/Pictures, then the issue resurfaces. The login screen changes back to the ugly default one. I feel like there's gotta be a setting or config file somewhere that's causing the problem. Could it be something in /home?

UPDATE 2:

Someone on reddit suggested changing the wallpaper from Firefox. This works, if I change the background from Firefox then both the Desktop and Login wallpapers match like they're supposed to. So that means it's gotta be some sort of permissions and/or groups related thing at this point, right?

Also just noticed that this created a file in /home called Firefox_wallpaper.png, so if LightDM has access to that, maybe the problem isn't my /home folder, but with my ~/Pictures or ~/Pictures/Wallpapers folders... hmm...

1

I used a pretty ugly workaround, but it gets the job done. Copy your desktop wallpaper into /usr/share/backgrounds, then change its name to warty-final-ubuntu.png, which should be the name of the current default login wallpaper. (If you want to keep the original, just change its name first to avoid it being overwritten.) Your desktop and login wallpaper should now match.

  • Yeah that could work, but I want the feature itself to work again, so that I don't have to do that workaround every time I change my wallpaper :/ – Abdul-Hakeem May 20 '16 at 15:43
  • You can also use dconf-editor to change the login screen. Again, you have to copy your desktop background image to /usr/share/backgrounds (I'm not sure if its necessary, but I also changed the ownership of the file to root). Then open dconf-editor and go to com > unity-greeter and change the value of background to /usr/share/backgrounds/<desktop background image>/. As far as not having to go though this process each time, I don't see how. The unity-greeter reads from /usr/share/backgrounds to retrieve the login screen background. If your image isn't there, it can't be displayed. – Alcuin Arundel May 20 '16 at 16:32
  • That was the default behavior before so I'm sure there must be a way to make it that way again right? Someone on reddit suggested changing the wallpaper from Firefox. This works, if I change the background from Firefox then both the Desktop and Login wallpapers match like they're supposed to. So that means it's gotta be some sort of permissions and/or groups related thing at this point, right? – Abdul-Hakeem May 21 '16 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.