I have searched high and low for the config file to change the server for the weather applet. Anyone have the file location? A system search yielded no results. The applet stopped working for me and my roomate several days ago.

  • switch to another weather service in preferences>weather services – Frank Schrijver May 19 '16 at 12:13
  • I could not find any such preferences, Frank. Is it possible that your reply relates to a different weather applet like "my weather indicator" or something similar? – UBod May 20 '16 at 6:46

Here is a solution (get the file and replace original):


I am using Mint 17.3 (64 bit) w/Mate DE and Linux Kernel and Cairo-Dock 3.4.0 and the file worked perfectly for me! Thanks for the fix! I just copied the file as root in /usr/lib/x86_64-linux-gnu/cairo-dock/libcd-weather.so, and now see my screenshot: https://personal.filesanywhere.com/FS/M.aspx?v=8a6b688d5d65aeba6fa4

| improve this answer | |
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Karl Richter May 26 '16 at 18:29
  • I used your fix as described above... it did not work for me. – Ubulindy May 28 '16 at 16:18

I had the same problem, and we are not alone: http://www.glx-dock.org/bg_topic.php?t=8945

The update to libcd-weather.so as suggested in Garry Garrison's answer (the link to the binary is also mentioned on http://www.glx-dock.org/bg_topic.php?t=8945) did not work for me. Anyway, I tried to fix it myself and I was successful. What I did was the following (on Ubuntu 16.04LTS with cairo-dock 3.4.1):

  1. I downloaded the package source using apt-get source cairo-dock-plug-ins
  2. In the files cairo-dock-plug-ins-3.4.1/weather/src/applet-config.c and cairo-dock-plug-ins-3.4.1/weather/src/applet-read-data.c, I changed the URLs http://xml.weather.com to http://wxdata.weather.com/wxdata.
  3. Then I followed the instructions presented in How to download, modify, build and install a Debian source package? in the "Classic" section of the first answer (first rebuild, then install).

After a restart of cairo-dock, the weather plug-in worked normally again. This is basically what is suggested as the necessary patch on http://www.glx-dock.org/bg_topic.php?t=8945, however, with some more details on how to actually perform this patch.

| improve this answer | |

I fixed weather plug-in on Kubuntu 14.04!!!

-remove all cairo-dock from Synaptic, and install cairo-dock-

sudo add-apt-repository ppa:cairo-dock-team/ppa

sudo apt-get update

sudo apt-get install cairo-dock cairo-dock-plug-ins

Then from https://drive.google.com/open?id=0B-XSYP5W-8Wea2NWTGJtSkxybEk

i copied the file as root in /usr/lib/x86_64-linux-gnu/cairo-dock/libcd-weather.so

And Cairo-Dock weather applet working!!!
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.