19

I'm trying to find the gnome terminal config file in Ubuntu 16.04, but having no luck whatsoever. I want the cursor not to stop blinking, and there's probably a timeout parameter I can change, but I can't find the file to do it. I know it can be done through dconf-editor, but for some reason that's not working (I think I removed some dependency or other).

  • 3
    dconf dump /org/gnome/terminal/legacy/profiles:/ – utopic eexpress Mar 15 '17 at 5:54
  • 2
    The comment of @utopiceexpress worked for me on 17.04. Loading the dumped config can be done with cat dump.txt | dconf load /org/gnome/terminal/legacy/profiles:/ – Fabian Streitel Aug 14 '17 at 20:10
  • 1
    @utopiceexpress Some of the settings are outside of the "profiles:" directory, so you should rather do dconf dump /org/gnome/terminal/. See also askubuntu.com/questions/967517/backup-gnome-terminal/967535. – egmont Oct 23 '17 at 13:13
13

There is no config file.

The gnome-terminal manages all its settings through dconf (or gconf in old Ubuntu releases) which is comparable to the Windows registry. It's a binary file optimized for quickly reading its values, you can not edit or view it manually like a text document.

If your dconf-editor or whatever tool you're trying to use is not working, you have to correct that error first.

Just for completeness, but probably you already saw those links (which mention only dconf/gconf, of course):
How do I disable the blinking cursor in gnome-terminal?
How to disable blinking cursor in Gnome 3.8?

  • 4
    "you can not edit or view it manually like a text document." But there is dconf dump and load unix.stackexchange.com/q/199836/49853 askubuntu.com/q/522833/40581 – LiveWireBT May 18 '16 at 21:36
  • Turns out my dconf-editor wasn't borked after all. I just had a bad case of the dumb. – Alcuin Arundel May 18 '16 at 21:46
  • @LiveWireBT You're right, there are always alternative tools. They can translate the binary dconf registry file into plain text and back as well as modify it. From the question's wording, I was just somehow thinking that there could be more stuff messed up and not only the graphical dconf-editor... – Byte Commander May 19 '16 at 5:01
1

I want the cursor not to stop blinking

GNOME Terminal doesn't offer a separate option for this, but it respects GNOME's default which is located in the dconf key /org/gnome/desktop/interface/cursor-blink-timeout (in seconds).

Beef up this to a giant value if you'd prefer the cursor to keep blinking, e.g.

dconf write /org/gnome/desktop/interface/cursor-blink-timeout 86400
1

NB: you won't have to install any program or remove any file.

To edit your gnome-terminal preferences without actually opening or using gnome-terminal go to

/root/usr/share/applications

Then locate Terminal in the folder.
Then open its properties by right clicking on Terminal.
There you'll see command.
This is actually what happens when you open terminal. So to edit the preferences, change the command to gnome-terminal --preferences.
Voila

After "repairing" the settings. Just close the preferences and then remove --preferences from the command in the properties window. Now just open the terminal as you normally would.

EDIT : If you are in a command line interface, then just use the command gnome-terminal --profile=default

  • Thanks for the answer. You implied that one navigates with a GUI file interface. I got to step 3 before realizing your answer does not apply to a command line interface. – wallyk Jun 1 '18 at 17:06
  • @wallyk yes it doesn't. Because I had somehow messed up with my gnome-terminal settings and I knew where was the fault. So I wanted a way to keep my configuration as it is and "repair" the terminal. As many methods mentioned about using dconf tools and deleting the configuration file, something that I wanted to keep as it is and change it back. – Z3T4 Z00K Jun 1 '18 at 19:04
  • @wallyk i found the solution to your problem. Check the answer – Z3T4 Z00K Jun 3 '18 at 4:38
  • @wallyk your welcome – Z3T4 Z00K Jun 4 '18 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.